Recent

Author Topic: install problem in Pas2JS_Widget  (Read 695 times)

arirod

  • New Member
  • *
  • Posts: 25
install problem in Pas2JS_Widget
« on: May 06, 2022, 05:33:16 am »
@Sven, hi!
I'm trying to install wigdet, which was downloaded from github and the compiler shows this error.
could you help me with this solution?
thanks,
Ari

from Brazil
Debian Buster, Laz 2.2.0 FPC 3.2.2

PascalDragon

  • Hero Member
  • *****
  • Posts: 4765
  • Compiler Developer
Re: install problem in Pas2JS_Widget
« Reply #1 on: May 06, 2022, 03:45:34 pm »
Which pas2js version are you using? Just to be sure that I check with the right one...

arirod

  • New Member
  • *
  • Posts: 25
Re: install problem in Pas2JS_Widget
« Reply #2 on: May 16, 2022, 07:29:33 pm »
Ok with laz 2.0.10 and pas2js 2.0.0...isso possible change namespace eg controls to wcl.controls? Tks

PascalDragon

  • Hero Member
  • *****
  • Posts: 4765
  • Compiler Developer
Re: install problem in Pas2JS_Widget
« Reply #3 on: May 17, 2022, 08:55:16 am »
Ok with laz 2.0.10 and pas2js 2.0.0...

Does this mean you also use Pas2JS 2.0.0 with Lazarus 2.2.0 where it fails or some other version?

isso possible change namespace eg controls to wcl.controls? Tks

You're not supposed to install the runtime package into the IDE anyway, so it makes no sense to do so.

cpicanco

  • Sr. Member
  • ****
  • Posts: 474
  • Programmer and Behavioral Scientist
    • Portfolio
Re: install problem in Pas2JS_Widget
« Reply #4 on: November 28, 2022, 06:49:31 am »
I was caught on that too. In my case, I installed Lazarus trunk using fpcupdeluxe (a couple of months ago) and downloaded pas2js_widget from GitHub today. Can you shed some more light on this?
« Last Edit: November 28, 2022, 06:51:57 am by cpicanco »

 

TinyPortal © 2005-2018