Forum > Databases

embedded Firebird app installation

(1/2) > >>

I have a Lazarus app with an embedded Firebird database developed on a pc with Firebird installed.  I installed the app on my laptop some time ago and it ran succesfully ther.   The laptop then acquired serious corruption and I did a full clean installation of Windows 10 pro and copied my app onto the laptop.   On starting it I get an error message :-

-unavailable database

The database(FDB)  is in a separate folder and the app reads an ini file to get the correct path.

I have copied into the app folder the followng:-
all from the development pc.

I tried to access the database from FlameRobin and received a message which included the following

SQLMessage -902    Unsuccesful execution caused by a System error that precludes successful execution of subsequent statements.
Engine Code: 335544721   Unable to complete network request to host "localhost"

Are the files I have copied over enough or have I missed something?   It all worked on the laptop before I had to do the full install and I cant recall what steps I took in putting the app on it initially.

I have looked at Firebird references to using the embedded server option and think I have done what it says.

and reading this link:
the first sentence is

--- Quote ---Embedded server on Windows

The Windows Embedded Server is a Superserver engine plus client rolled into one library, called fbembed.dll.

--- End quote ---

Besides the dll you mentioned you also need the intl and udf directories.

The link Zvoni gave has a description of everything you need.

And if you use FlameRobin in embedded state you also need to copy all those things to the directory where flamerobin.exe is. And don't use it the same time as your own application.

What version of Firebird are you using? If version 3 or higher then you must have the "plugins" directory along with the file "engine12.dll" (FB 3) or "engine13.dll" (FB 4).

Thanks I read that fbembed.dll should have its name changed to fbclient.dll - anyway I I have just tried changing it's name but same error.  Also FlameRobin fails.
The instruction to rename is further down in the document you refer to.


[0] Message Index

[#] Next page

Go to full version