Recent

Author Topic: Lazarus & MacOSX Maverick  (Read 478 times)

sunjob

  • New Member
  • *
  • Posts: 21
Lazarus & MacOSX Maverick
« on: April 25, 2022, 03:11:46 am »
Good Afternoon!

can't start Lazarus on MacOSX. tried installing all versions that are available on sourceforge

different versions/variants produce roughly the same thing

Code: [Select]
Cannot find db used by fcllaz of package FCL
Cannot find gl used by agl

simple fpc programs in the console are assembled without problems

first, in Lazarus, in a dialogue with PATH - it gave a warning that fpc.cfg was not found (generated manually, placed "where necessary")

I guess the problem: case sensitive file systems (boot & home volume).

in MacOSX 10.6.x SnowLeopard - there were corresponding problems (hoped that these sores won)

need exactly "Case-Sensitive File System"

Code: Pascal  [Select][+][-]
  1. - Mac OSX 10.9.5 Maverick
  2. - XCode 6.2  + command tools
  3. - fpc/lazarus - on sourceforge, all ver.

Mavericks_Xcode_5
Lazarus_on_macOS
sourceforge.net

thanks


« Last Edit: April 25, 2022, 03:13:22 am by sunjob »

trev

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1989
  • Former Delphi 1-7, 10.2 user
Re: Lazarus & MacOSX Maverick
« Reply #1 on: April 25, 2022, 08:26:58 am »
The error messages indicate a faulty installation on macOS complicated by attempts at multiple installs of different versions.

My advice is to remove all current Lazarus and FPC installations including the Lazarus config files and the FPC config file (see the Wiki article Uninstalling Lazarus on macOS) and then follow the detailed installation instructions in this Wiki article.

I'm not convinced that the case-sensitive file systems are the source of the errors based on my past experience with those exact errors (search the forum if you are interested).
Lazarus 2.3, FPC 3.3.1 macOS 12.3.1 x86_64 Xcode 13.4
Lazarus 2.3, FPC 3.3.1 macOS 12.3.1 aarch64 Xcode 13.4

sunjob

  • New Member
  • *
  • Posts: 21
Re: Lazarus & MacOSX Maverick
« Reply #2 on: May 01, 2022, 06:17:24 am »
all ok, trouble on /etc/fpc.cfg - need сonfigure correctly :о)

 

TinyPortal © 2005-2018