Forum > Linux

Lazarus can't find exeutable! Linux ubuntu...[SOLVED]

(1/3) > >>

Robert W.B.:
Todays security needs and app store to protect you from hacker code, so it is important you can install your favorite apps that's in that enviroment.
I tried to install Lazarus from Ubuntus appstore but without no success! I know I can get a fix for this in terminal but this is not secure if you don't know, what the code is installing! I been very pissed, when installed gcc for Codeblocks from a link and get the bootsector virus in Win 10 and have to install everything again!
So can I ask for Lazarus team to correct this in Ubuntu appstore.
Best regards and thanks in advance.
Robert  :)

That is the Appstore team's task, not Lazarus'.

Robert W.B.:
Ok. I see. Thanks for the info.

Sorry Robert, the App Store approach adds absolutely no security to a product like Lazarus. The only way it could is if "they",  were to go over the source code, line by line, looking for something that should not be there. Can you imagine how long that would take each time Lazarus has a release ? And their chance of finding something well hidden ?

Debian them selves do have some FPC/Lazarus people, I doubt the other distros do.

No, they rely on the reputation of the product, they see Lazarus is open source and that people are openly invited to examine and contribute to the code and reason that a conspiracy would be just too hard to hide. In the case of Ubuntu, they just take it from Debian.

So, getting Lazarus from your App Store is no safer, indeed, may be a little less safe because its been through several extra sets of hands, than direct from Lazarus's own distribution means.

That being said, I am surprised that the Ubuntu version of Lazarus is broken, they get it pretty much direct from Debian and while its most certainly not how I suggest you set it up, it does work. Hmm, unless you have the one intended for Bullseye, it had a self build problem that has been fixed in BackPorts.

You did not say what version of Ubuntu you are using and I cannot possibly read the error message you posted. Mind if I suggest that as a software developer your self, you should know better than that ?


Just a side note - in U22.04, Lazarus is listed in the App Store as "potentially unsafe" !
But at least they have stopped describing anything not their own (such as my app) as "proprietary", that has bugged me for a long time.



[0] Message Index

[#] Next page

Go to full version