Recent

Author Topic: Lentitud en arranque Lazarus y no responde.  (Read 632 times)

delphin

  • New Member
  • *
  • Posts: 21
Lentitud en arranque Lazarus y no responde.
« on: April 19, 2022, 09:35:07 am »
Hola amigos:

Windows 10 y ultima version de Lazarus, he observado que me tarda mucho en arrancar el ide unos 15 segundos , anteriormente era muy muy rapido. Entonces abriendo el administrador de tareas, observo que a los 9 ó 10 seg. se queda en "No responde" y al terminar de arrancar a los 15 seg. ya desaparece. y su funcionamiento es normal , como sabeis es sorprendentemente liviano y consume poquisima memoria.
Observado en equipo de sobremesa y portatil, he desinstalado todos los componentes que instale y sigue igual. (lazreport, rx, zeos)

Alguno de vosotros le pasa esto, lo habeis comprobado. ?

Muchisimas gracias por vuestra ayuda.

Jose.

mosquito

  • Full Member
  • ***
  • Posts: 116
Re: Lentitud en arranque Lazarus y no responde.
« Reply #1 on: April 19, 2022, 11:03:46 am »
Hola Jose, no comentas si es la última versión estable o de desarrollo. Tampoco si son los binarios oficiales o instalación sandbox tipo fpcupdeluxe.


Aunque no conozco mucho Windows, puedes probar añadir la carpeta de Lazarus a la lista de excepciones de Windows Defender u otro antivirus. Esto recuerdo que retrasaba el arranque de algunos programas mucho. Aunque si antes no te pasaba.... si no es mucho trauma, yo haría una instalación paralela con fpcupdeluxe, que es super-rápida y probaría para descartar. O reinstalar la oficial.

Lo de los componentes, puedes probar más bien (suponiendo que no lo hayas hecho) a hacer un cleanUp+buildAll en las opciones de reconstrucción del IDE.

Salu2.
« Last Edit: April 19, 2022, 11:05:59 am by mosquito »

delphin

  • New Member
  • *
  • Posts: 21
Re: Lentitud en arranque Lazarus y no responde.
« Reply #2 on: April 19, 2022, 04:24:28 pm »
Hola amigo.

Diste en el clavo, era el antivirus de Microsoft que le da por chequear los .exe comprimidos (les tiene predileccion), no habia pensado en eso.
Pensaba en los componentes que habia instalado, en fin ahora me carga en 5 ó 6 seg. sin quedarse sin responder, fantastico teniendo en cuenta que
Delphi Community Sydney tarda 20 seg. y que consume 10 veces mas memoria que Lazarus.

Repito muchisimas gracias compañero, me has quitado una preocupacion.

Jose.

daragor

  • Jr. Member
  • **
  • Posts: 60
    • Blog Webscom
Re: Lentitud en arranque Lazarus y no responde.
« Reply #3 on: April 20, 2022, 04:04:16 pm »
Excelente, me pasa lo mismo en windows 10. voy a probar con poner la carpeta en excepciones.
Inculcando el software libre.
https://www.webscom.com.ar

mosquito

  • Full Member
  • ***
  • Posts: 116
Re: Lentitud en arranque Lazarus y no responde.
« Reply #4 on: April 20, 2022, 07:37:55 pm »
@Jose, me alegro  ;) ;


Si ves que con el tiempo Windows Defender empieza a pasar de nuevo por el ejecutable, mete en excepciones tanto la carpeta completa de Lazarus como los ejecutables sensibles por separado (lazarus, lazbuild, fpc, gdb...). No me digas por qué, pero funciona.

 

TinyPortal © 2005-2018