Forum > GTK

gtk2 steals 8 seconds

(1/2) > >>


If I start an app in the IDE it takes 7500 to 8500 ms between FormCreate and FormActivate. That's bothering.

If I start the same app from a console or a filemanager it takes 400..500 ms - that's ok.

System is Linux64, Suse Tumbleweed, fpc 3.2.2 Laz 2.2.0, gtk2

Happend maybe a week ago after a rolling release of Tumbleweed.

Suspected is something of gtk2.

Any ideas or experience?


Hmm, there was an issue involving a dbus timeout with gtk2, that was 20 seconds from memory -,47240.msg376845.html#msg376845

Its a long read ....

It was never resolved completely IMHO, related to Ubuntu leaving out some necessary package. But seems to pop up again and again ....



Thanx for the reply.

Still not solved.

In the 8 seconds when the app tries to start from the IDE the gdb consumes betwenn 70% and 90% of CPU time, Measured by Top.


If it is only in the debugger.....

Well maybe gdb is loading debug info? Maybe your update installed debug info for gtk libraries (or some other libs that are loaded).

That would explain why the time is spent in gdb. And yes, gdb could be holding/pausing the app during that time.

You can disable gdb loading debug info for libs. Set  "DisableLoadSymbolsForLibraries" to "True". See:


Thanx for your tipp.

I tried that but nothing changed.

Then I changed the build mode to "Release" - but nothing changed.

All the devel packages for gtk2 are installed.

I'm running out of ideas.



[0] Message Index

[#] Next page

Go to full version