Forum > Linux

How to Installation Lazarus 2.2.0 on linux mint?

(1/6) > >>

Rama Can:
How to installation on Linux mint?
I always have problem when I install latest Lazarus on Linux Mint, can anyone help me with this for my college assignment

before I install, I first uninstalled Lazarus version 2.0.6
then download
fpc-laz_3.2.2_amd64.deb
fpc-src_3.2.2_amd64.deb
lazarus-project_2.2.0-0_amd64.deb

then i run this command in terminal


--- Quote ---sudo dpkg -i fpc-laz_3.2.2_amd64.deb

sudo dpkg -i fpc-src_3.2.2_amd64.deb

sudo dpkg -i lazarus-project_2.2.0-0_amd64.deb
--- End quote ---

then get wrong


--- Quote ---dpkg: regarding fpc-laz_3.2.2_amd64.deb containing fpc-laz:
 fpc-laz conflicts with fp-compiler
  fp-compiler:amd64 (version 3.0.4+dfsg-23) is present and installed.
  fp-compiler-3.0.4:amd64 provides fp-compiler and is present and installed.

dpkg: error processing archive fpc-laz_3.2.2_amd64.deb (--install):
 conflicting packages - not installing fpc-laz
Selecting previously unselected package fpc-src.
dpkg: regarding fpc-src_3.2.2_amd64.deb containing fpc-src:
 fpc-src conflicts with fpc-source
  fpc-source-3.0.4 provides fpc-source and is present and installed.

dpkg: error processing archive fpc-src_3.2.2_amd64.deb (--install):
 conflicting packages - not installing fpc-src
dpkg: warning: files list file for package 'dbconfig-common' missing; assuming package has no files currently installed
(Reading database ... 412251 files and directories currently installed.)
Preparing to unpack lazarus-project_2.2.0-0_amd64.deb ...
Unpacking lazarus-project (2.2.0) ...

dpkg: dependency problems prevent configuration of lazarus-project:
 lazarus-project depends on fpc-laz (= 3.2.2); however:
  Package fpc-laz is not installed.
 lazarus-project depends on fpc-src (= 3.2.2); however:
  Package fpc-src is not installed.

dpkg: error processing package lazarus-project (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu2) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24+linuxmint1) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for shared-mime-info (1.15-1) ...
Processing triggers for man-db (2.9.1-1) ...
Errors were encountered while processing:
 fpc-laz_3.2.2_amd64.deb
 fpc-src_3.2.2_amd64.deb
 lazarus-project
--- End quote ---

nouzi:
First remove old version


--- Code: Bash  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---apt remove fpc-laz*apt remove lazarus*apt autoremove &&  apt clean 
and try again

Rama Can:
still with the same error

Thaddy:
Not remove, but purge.

Rama Can:
still with the same error :(

Navigation

[0] Message Index

[#] Next page

Go to full version