Forum > QT

[SOLVED] Project fails to build with Qt5

(1/1)

TCH:
I have Devuan 2 ASCII (which is Debian 9 Stretch without systemd) and Qt5 is 5.7.1. The Qt5 wiki page of Lazarus says it is tested with 5.6.2, so 5.7 should be, OK, right? LibQt5Pas is version 2.6~beta-4~bpo9+1. The error is the following:
--- Code: ---Error: /usr/share/lazarus/2.2.0/lcl/units/x86_64-linux/qt5/qtwidgets.o: In function `SETTEXTHINT':
Error: /usr/share/lazarus/2.2.0/lcl/interfaces//qt5/qtwidgets.pas:20038: undefined reference to `QTextEdit_setPlaceholderText'
--- End code ---
Is something missing, or it is a mismatch? What is the minimum Qt5 for Lazarus 2.2?

AlexTP:
IMO you have too old Qt5 and/or libQt5Pas installation, i remember this error when new app was used with old libqt5pas.

AlexTP:
Try the new libQt5Pas https://github.com/davidbannon/libqt5pas/releases

TCH:
Thanks, after i compiled libQt5Pas from source, it works.

Navigation

[0] Message Index

Go to full version