Recent

Author Topic: [SOLVED] Project fails to build with Qt5  (Read 401 times)

TCH

  • Full Member
  • ***
  • Posts: 184
[SOLVED] Project fails to build with Qt5
« on: March 21, 2022, 05:30:39 pm »
I have Devuan 2 ASCII (which is Debian 9 Stretch without systemd) and Qt5 is 5.7.1. The Qt5 wiki page of Lazarus says it is tested with 5.6.2, so 5.7 should be, OK, right? LibQt5Pas is version 2.6~beta-4~bpo9+1. The error is the following:
Code: [Select]
Error: /usr/share/lazarus/2.2.0/lcl/units/x86_64-linux/qt5/qtwidgets.o: In function `SETTEXTHINT':
Error: /usr/share/lazarus/2.2.0/lcl/interfaces//qt5/qtwidgets.pas:20038: undefined reference to `QTextEdit_setPlaceholderText'
Is something missing, or it is a mismatch? What is the minimum Qt5 for Lazarus 2.2?
« Last Edit: March 21, 2022, 09:52:31 pm by TCH »

AlexTP

  • Hero Member
  • *****
  • Posts: 1846
    • UVviewsoft
Re: Project fails to build with Qt5
« Reply #1 on: March 21, 2022, 06:10:25 pm »
IMO you have too old Qt5 and/or libQt5Pas installation, i remember this error when new app was used with old libqt5pas.

AlexTP

  • Hero Member
  • *****
  • Posts: 1846
    • UVviewsoft
Re: Project fails to build with Qt5
« Reply #2 on: March 21, 2022, 06:12:46 pm »

TCH

  • Full Member
  • ***
  • Posts: 184
Re: Project fails to build with Qt5
« Reply #3 on: March 21, 2022, 09:52:00 pm »
Thanks, after i compiled libQt5Pas from source, it works.

 

TinyPortal © 2005-2018