Forum > macOS / Mac OS X

Running Lazarus Trunk on M1

<< < (2/4) > >>

I went with the "Step 5: How to configure the Debugger", there was not any "LLDB debugger (with fpdebug) (Beta)" so I installed, and now it does not freeze while debugging.
Next step I tried to write a simple program, with a WriteLn and ReadLn. It seems it opens and closes, I checked LaunchNewTerminal option in debugger and it opens an empty terminal and nothing else, and it makes the Lazarus frozen on the debugging and no solution unless logging out.

So it seems these are the problems:
- fpcupdelux aarch64 does not open in M1 Mac.
- fpcupdelux does not install fpdebug for Mac version of Lazarus as it seems the right debugger.
- No output in terminal for simple programs.
- When Lazarus froze on Mac while debugging, it does not let go and keeps Lazarus open. (Even if I force close the zombie, another instance can not open with error of there is another Lazarus running)

And for me specifically, I do not know how to config a Lazarus on Mac, even with the snapshots of trev, it bugs about config files, compiler and other things.

Any help.

note folder x86_64 can be different if different architecture ie Arch64 etc
name of fpc compiler can be different if different architecture ie fpca??

Important note.

The folder you have installed lazarus fpc should not have any spaces in it, lots of the utilities will have issues.

Best to install in The root of a Hard Disk/Volume in a Folder with no spaces like MacHd://lazarus_trunk.

This is true for all Os's

Thank you Josh but theres are addresses for Windows and I did not use space. I am familiar with that, but for Mac and for example for Trev snapshots, I do not know where are the fpc binary and fpppkg.cfg are.
@Trev, can you please share an screenshot of your config address?

in fpcupdeluxe
in the extra tab
you have a few check routines and create config routines.
have you tried any of those.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version