Forum > Windows (32/64)

Lazarus v2.0.8 crash


Last time I built the project it worked.

Now (a few months later) without having touched any of the project files, I get this:

--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---c:\temp>lazbuild --bm=release main.lpiHint: (lazarus) Missing state file of FCL 1.0.1: C:\Lazarus\packager\units\i386-win32\FCL.compiledHint: (lazarus) Missing state file of LazUtils 1.0: C:\Lazarus\components\lazutils\lib\i386-win32\LazUtils.compiled   $0044715B  $004456BC  $004021CB  $006B8FCA  $004D383A  $004D368A  $004CE65F  $004CDBC8  $00403E5CError: (lazbuild) Ambiguous unit foundThe file "C:\Lazarus\components\lazutils\avglvltree.ppu"was found in one of the source directories of the package LazUtils 1.0 and looks like a compiled unit. Compiled units must be in the outputdirectory of the package, otherwise other packages can get problems using this package. Delete ambiguous file?lazbuild is non interactive, aborting now. c:\temp>lazbuild --version2.0.8 
I tried using -B option with lazbuild but I still get this crash.

Any ideas?


[0] Message Index

Go to full version