Recent

Author Topic: Problem with diacritics  (Read 1105 times)

Xatrix

  • New Member
  • *
  • Posts: 15
Problem with diacritics
« on: March 08, 2022, 10:18:48 am »
Hi Group !
No diacritics in the IDE, such as ĄĆŁŃŚó ... etc.
What should I do to be able to use these characters?
I can't find it anywhere in SETTINGS

af0815

  • Hero Member
  • *****
  • Posts: 996
Re: Problem with diacritics
« Reply #1 on: March 08, 2022, 10:36:17 am »
a ) System / fpc / Lazarus ?
b ) In strings no problem here, in code for names,... forbidden

I use win10/64  with en/de/gr Keyboard Layout . It depends only my keyboardlayout

Is your sourcecodefile UTF-8. Tools-> Convert Encoding of Project/Package
« Last Edit: March 08, 2022, 10:40:53 am by af0815 »
regards
Andreas

Xatrix

  • New Member
  • *
  • Posts: 15
Re: Problem with diacritics
« Reply #2 on: March 08, 2022, 11:03:51 am »
a ) Lazarus
b ) in string only.For example ShowMessage('Ó'); // and i see Online Package Manager ;-))

My codepage is UTF-8

dbannon

  • Hero Member
  • *****
  • Posts: 2045
    • tomboy-ng, a rewrite of the classic Tomboy
Re: Problem with diacritics
« Reply #3 on: March 08, 2022, 11:26:24 am »
Might be a question of how you enter the extended characters ?
Perhaps -
https://gitlab.com/freepascal.org/lazarus/lazarus/-/issues/38454

Davo
Lazarus 2, Linux (and reluctantly Win10, OSX)
My Project - https://github.com/tomboy-notes/tomboy-ng

PascalDragon

  • Hero Member
  • *****
  • Posts: 4282
  • Compiler Developer
Re: Problem with diacritics
« Reply #4 on: March 08, 2022, 01:24:26 pm »
a ) Lazarus

That wasn't an "either or" question, but you were asked to name all three, your system, your FPC version and your Lazarus version (and in case of Lazarus also whether you use Qt or GTK2/3 if you're on a platform that uses any of these).

Xatrix

  • New Member
  • *
  • Posts: 15
Re: Problem with diacritics
« Reply #5 on: March 08, 2022, 03:10:05 pm »
Ah, okay
The answer is :  Windows 10 64 bit / Lazarus 2.2.0 / FPC 3.2.2

paweld

  • Sr. Member
  • ****
  • Posts: 404
Re: Problem with diacritics
« Reply #6 on: March 08, 2022, 04:19:57 pm »
Tools > Options > Editor > KeyMappings - disable all sequences with Ctrl + Alt and A, C, L etc.
Best regards
paweld
---
Lazarus trunk / FPC stable

 

TinyPortal © 2005-2018