Forum > QT

When will Linuxes have the new version of libQt5Pas?

<< < (2/4) > >>

dbannon:
OK, I have rushed out some debs and rpms for the new 1.2.10 libs.

https://github.com/davidbannon/libqt5pas/releases

I have not tested the packaging, sorry, travelling and don't have whats needed. So, someone may like to test and report back.

Davo

zeljko:
Thanks @dbannon, that is one solution - packaging independent rpms and debs :)

zeljko:
Maybe adding packages link to the Qt5 widgetset wiki page would be good thing.

dbannon:

--- Quote from: zeljko on March 01, 2022, 04:30:40 pm ---Maybe adding packages link to the Qt5 widgetset wiki page would be good thing.

--- End quote ---

its actually mentioned there already but maybe now we will be needing it again, a bit more, I will make it a touch more prominent. I guess we will see a new Lazarus in a few months and distros like Debian will be using 1.2.9 for another two years.

Davo

Edit - updated the wiki a bit, see https://wiki.freepascal.org/Qt5_Interface

prof7bit:
As long as I can remember Lazarus (even Trunk) and with it all Lazarus compiled applications have been working with the libqt4/5pas that came from the Linux distribution.

Up until yesterday I could just declare libqt5pas a normal dependency of my apps and have it installed automatically from their repository.

I would very much like to keep it that way and not introduce API breaking changes in the middle of a fixes branch.

Please revert this heavily breaking change in fixes, apply it in main only, so users can continue to deploy their applications without needing to ship their own versions of distro packages.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version