Forum > QT

Help setting up environment for developing for steam link


Hello there!

I recently got a used steam link and saw, that it runs linux 3.8 and one can access it and install custom apps.
I also saw that it supports OpenGL ES 2.0, Qt 5.14.1 aswell as SDL 2.0 and that there is an sdk (

I tried installing an ARM cross-compiler for Lazarus and tried compiling a small test application with Qt to run on the stem link.
When I copied it over, it didn't start from the App screen, so i tried executing it from ssh to get mor info and sure enough, "libQt5Pas" is missing. I tried copying an ARM version of libQt5Pas over and tried it again with low expectations and it failed, because other libraries are missing and the libc version is wrong.

So I looked at the sdk, because that has the right library versions and even an example for a Qt application written in C++, but I don't know how to set it up to work with Lazarus/FPC.

Can anyone tell me, how I would set this up, so FPC uses the right libraries and maybe build libQt5Pas in the right environment?

Thanks in advance!

There's somewhere on forum link to arm* libQt5Pas and other Qt5 libs AFAIR. Maybe even on Qt subforum.

As stated, I already tried using pre compiled arm libs i found on here, but they didn't work, because I think the libc on the steam link is dfferentnt to the one they were compiled for.

I just tried again to compile a simple qt app with a cross compiler and move it to the steam link.
I then copied the CrossLibsLinuxARM, libQT5Pas 2.6 arm and libqtx11extras arm into a lib folder near the executable and tried running it from ssh to get errors and I got the following error. Maybe it's from mismatched libraries, but I'm not sure:

--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---./project1: lib/ version `CXXABI_1.3.9' not found (required by lib/ lib/ version `CXXABI_1.3.9' not found (required by /usr/local/Qt-5.14.1/lib/ lib/ version `CXXABI_1.3.9' not found (required by /usr/local/Qt-5.14.1/lib/ lib/ version `CXXABI_1.3.9' not found (required by /usr/local/Qt-5.14.1/lib/ lib/ version `CXXABI_1.3.9' not found (required by /usr/local/Qt-5.14.1/lib/ lib/ version `GLIBCXX_3.4.21' not found (required by /usr/local/Qt-5.14.1/lib/ lib/ version `CXXABI_1.3.9' not found (required by /usr/local/Qt-5.14.1/lib/ 
Ideal would be, if I could set up Lazarus to use the libraries and so on from the sdk.


[0] Message Index

Go to full version