Recent

Author Topic: [Solved] Is this patch needed for latest IDE?  (Read 796 times)

AlexTP

  • Hero Member
  • *****
  • Posts: 1765
    • UVviewsoft
[Solved] Is this patch needed for latest IDE?
« on: January 25, 2022, 07:58:05 pm »
I updated the IDE to the last dev-version. I did not compile itself then.
FPC shown the error "cannot find unit Debugger".
I found this unit in Laz subfolder and added the required package "DebuggerIntf" to the project lazarus.lpi.
Now it can compile itself.
Patch
Code: [Select]
diff --git a/ide/lazarus.lpi b/ide/lazarus.lpi
index 3579ff1f18..6ce833eac5 100644
--- a/ide/lazarus.lpi
+++ b/ide/lazarus.lpi
@@ -37,6 +37,9 @@
       <FormatVersion Value="2"/>
     </RunParams>
     <RequiredPackages>
+      <Item>
+        <PackageName Value="DebuggerIntf"/>
+      </Item>
       <Item>
         <PackageName Value="LazDebuggerIntf"/>
       </Item>
« Last Edit: January 26, 2022, 10:10:15 pm by Alextp »

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 7865
  • Debugger - SynEdit - and more
    • wiki
Re: Is this patch needed for latest IDE?
« Reply #1 on: January 25, 2022, 08:59:18 pm »
No patch needed.

A new core package was added to the IDE. When that happens the IDE can not rebuild itself (i.e. an older IDE can not build the newer codebase). You need an updated IDE exe, to build it.

- This can be obtained using the makefile.
- Or the package can be opened and installed by hand, and then it will work (at least for the current case / workaround).

Because core packages are hardcoded, they are only found by an IDE that has the hardcode code compiled into it. An IDE without that added code, does not know about the package, therefore such an IDE can't build code that needs that package.

It has happened before. It will happen again...

Btw the package is "IdeDebugger".  And that will pull in LazDebuggerIntf too.

"DebuggerIntf" (which you added) is an older package, it should be found, unless your IDE executable is many years old.
"DebuggerIntf"  does not contain Debugger. Even if FPC mentions it in one of the error messages. Read the error again....


 

TinyPortal © 2005-2018