Recent

Author Topic: Wrong version in ide/version.inc: 2.0.10+dfsg-4  (Read 2225 times)

marsheng

  • Jr. Member
  • **
  • Posts: 53
Wrong version in ide/version.inc: 2.0.10+dfsg-4
« on: January 22, 2022, 10:41:52 am »
I have installed Lazarus on a raspberry pi 4.

When I run the IDE I get

Warning: wrong version in ide/version.inc: 2.0.10+dfsg-4

I thought that a simple search would have given a solution, as I can't be the only one, but alas not.
My Library file is usr/lib/lazarus/2.0.10/.
Still seems to compile ok but as the message says, it give lots of errors.
How do I proceed ?

Thanks Wallace

MarkMLl

  • Hero Member
  • *****
  • Posts: 4163
Re: Wrong version in ide/version.inc: 2.0.10+dfsg-4
« Reply #1 on: January 22, 2022, 01:12:18 pm »
Earlier discussion probably relevant:

https://forum.lazarus.freepascal.org/index.php/topic,56937.msg423226.html#msg423226

Not sure what the resolution state is. This is not something that's affected me since I always build FPC and Lazarus from scratch: note that you've not said explicitly where you've got your copies (the RPi repositories, or the FPC/Lazarus projects?).

In "Advanced Search", double-quotes around e.g. "wrong version" treats the words as a phrase.

MarkMLl


MT+86 & Turbo Pascal v1 on CCP/M-86, multitasking with LAN & graphics in 128Kb.
Pet hate: people who boast about the size and sophistication of their computer.
GitHub repositories: https://github.com/MarkMLl?tab=repositories

dbannon

  • Hero Member
  • *****
  • Posts: 2021
    • tomboy-ng, a rewrite of the classic Tomboy
Re: Wrong version in ide/version.inc: 2.0.10+dfsg-4
« Reply #2 on: January 22, 2022, 01:33:20 pm »
He/She definitely got them direct from the Debian repository.

Its a (major) problem in Bullseye and is not expected to get fixed. Personally, I'd strongly recommend you install Lazarus from source, its very easy and you end up with a much better install. Its fixed in Testing but thats probably a bit raw. You can fiddle your apt config to get just lazarus from Testing but its really not worth the effort, build from src.

Alternatively, if you want to continue with your existing install, manually edit the file ide/version.inc

https://wiki.freepascal.org/Installing_Lazarus_on_Linux#Build_Lazarus_from_Source

Davo

Lazarus 2, Linux (and reluctantly Win10, OSX)
My Project - https://github.com/tomboy-notes/tomboy-ng

Thaddy

  • Hero Member
  • *****
  • Posts: 11517
Re: Wrong version in ide/version.inc: 2.0.10+dfsg-4
« Reply #3 on: January 22, 2022, 01:37:19 pm »
Simply use fpcupdeluxe. Works great on a Raspberry Pi too.
Путин преступник. Россияне дезинформированы.

marsheng

  • Jr. Member
  • **
  • Posts: 53
Re: Wrong version in ide/version.inc: 2.0.10+dfsg-4
« Reply #4 on: January 22, 2022, 11:22:26 pm »
Thanks for the replies.

Learned a few things on the way, update gave errors so cleared the lists and redownloaded and now all ok.

Everything was however up to date but still errors.

Not sure how to run

https://wiki.freepascal.org/fpcupdeluxe

Exec=/P/s/lazarus/lazarus --pcp="/P/s/config_lazarus"

PS Trying desperately to swap to Linux after 30 years if MS.

ottod

  • New member
  • *
  • Posts: 9

 

TinyPortal © 2005-2018