Recent

Author Topic: Lazarus 2.2.0 macOS debugging with lldb  (Read 429 times)

trev

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1983
  • Former Delphi 1-7, 10.2 user
Lazarus 2.2.0 macOS debugging with lldb
« on: February 04, 2022, 10:43:52 pm »
From https://forum.lazarus.freepascal.org/index.php/topic,58045.msg433415.html#msg433415

Quote
With the original [Lazarus 2.2.0] Intel x86_64 IDE build and LLDB, I can compile both aarch64 and x86_64 apps, but I found it will only debug the x86_64 app.

With the [Lazarus 2.2.0] aarch64 IDE build and LLDB, I can compile and debug both app types.  this is the preferred setup.

Is this expected behaviour?
Lazarus 2.3, FPC 3.3.1 macOS 12.3.1 x86_64 Xcode 13.4
Lazarus 2.3, FPC 3.3.1 macOS 12.3.1 aarch64 Xcode 13.4

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 7943
  • Debugger - SynEdit - and more
    • wiki
Re: Lazarus 2.2.0 macOS debugging with lldb
« Reply #1 on: February 04, 2022, 11:25:09 pm »
I don't know. I don't have M1. I also don't know which error happens if it doesn't work. (Or does it fail without err msg?)

Could be something in the IDE. Could be the OS restricting permissions. ....

trev

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1983
  • Former Delphi 1-7, 10.2 user
Re: Lazarus 2.2.0 macOS debugging with lldb
« Reply #2 on: February 05, 2022, 08:06:48 am »
The issue concerns the Intel, not M1, system according to the person who reported it.
Lazarus 2.3, FPC 3.3.1 macOS 12.3.1 x86_64 Xcode 13.4
Lazarus 2.3, FPC 3.3.1 macOS 12.3.1 aarch64 Xcode 13.4

 

TinyPortal © 2005-2018