Recent

Author Topic: [Solved] Just installed 2.2, cannot rebuild IDE  (Read 1392 times)

fmolina

  • New Member
  • *
  • Posts: 40
[Solved] Just installed 2.2, cannot rebuild IDE
« on: January 17, 2022, 02:55:44 pm »
Removed old lazarus version (2.0.12), downloaded and installed 2.2.0
Open the IDE, without changing anything, clean rebuild IDE. It stops with the following errors:
Quote
Compilar paquete zdbc 7.2.8: Código de salida 1, Errores: 3, Advertencias: 3, Sugerencias: 3
ZDbcUtils.pas(966,20) Hint: Local variable "Bytes" of a managed type does not seem to be initialized
ZDbcUtils.pas(1064,20) Hint: Local variable "Bytes" of a managed type does not seem to be initialized
ZDbcCache.pas(1480,19) Warning: function result variable of a managed type does not seem to be initialized
ZDbcCache.pas(2075,63) Warning: function result variable of a managed type does not seem to be initialized
ZDbcCache.pas(2120,26) Warning: function result variable of a managed type does not seem to be initialized
ZDbcCache.pas(218,25) Hint: Parameter "ColumnIndex" not used
ZDbcCache.pas(4429,13) Error: Incompatible types: got "Boolean" expected "Int64"
ZDbcCache.pas(4443,17) Error: Incompatible types: got "ShortInt" expected "Boolean"
ZDbcCache.pas(4445,17) Error: Incompatible types: got "ShortInt" expected "Boolean"
The editor windows shows what can be seen in the attached capture.
Removed zcomponent 7.2.8 form packages list an rebuild IDE. Identical result!
This is a package I never used, BTW
What is wrong?
Thanks
« Last Edit: January 17, 2022, 05:41:44 pm by fmolina »

wp

  • Hero Member
  • *****
  • Posts: 9604
Re: Just installed 2.2, cannot rebuild IDE
« Reply #1 on: January 17, 2022, 03:15:00 pm »
This is a package I never used, BTW
At least, you installed it... Because zcomponent belongs to ZEOS, and this is not distributed with Lazarus. Do not install packages which you do not use. They can cause trouble for no benefit.

Two ways to fix it (there are probably more...):

There is another discussion about the ZEOS libarary today that its incompatibility with fpc 3.2.2 has been fixed today. So: Start Lazarus, go to "Package" > "Online package manager". Scroll down to "ZEOS Dbo", check it an install it. It should work - this was reported in the other thread today. If you really do not need ZEOS you can install it later again via "Online package manager". Maybe you can even skip the re-installation.

Another way: Since you already marked the "zcomponent" package for uninstallation it is probably enough to do a clean rebuild of the IDE. This is the usual solution if the IDE does not build after a package installation/deinstallation. Go to "Tools" > "Configure Build Lazarus". In the "clean up" box check "Clean all" and "Switch after building to automatically". Then "Build".
Mainly Lazarus trunk / fpc 3.2.0 / all 32-bit on Win-10, but many more...

fmolina

  • New Member
  • *
  • Posts: 40
Re: Just installed 2.2, cannot rebuild IDE
« Reply #2 on: January 17, 2022, 05:41:05 pm »
Thanks Werner.
However, clean build didn't worked. zcomponent did not showed anymore in the package install/uninstall dialog, but the errors still appeared. OPM showed zcomponent "partially" installed, but could not uninstall. After some digging, I found the cause: zcomponent is required by pascalscada, wich I installed sometime ago; removing it solved the issue.
Regards

 

TinyPortal © 2005-2018