Forum > macOS / Mac OS X

Linking error: Unsupported target architecture

<< < (2/2)

trev:
I had a similar issue rebuilding the IDE from within the IDE (to get a native aarch64 version):


--- Quote ---    make[2]: *** [lazarus] Error 1
    make[1]: *** [idepkg] Error 2
    Error: make: *** [idepkg] Error 2
    Error: Unsupported target architecture -Paarch64, invoke the "fpc" compiler driver instead.
--- End quote ---

which was a little weird because the Preferences > Compiler executable was set to /usr/local/bin/fpc. The rather unintuitive solution (given the compiler error) was to change that to /usr/local/lib/fpc/3.2.2/ppca64 instead.

VTwin:
To clarify my earlier response, note that there is a configuration folder ".lazarus" in your home folder. If you look inside you will see "environmentoptions.xml" that contains paths for the compiler, etc.

My guess is that the folder was created during your first (faulty) install, and retained the old settings when you reinstalled. As I recall, there is an option during installation to remove the old settings, instead of upgrading. Did you do that?

By the way, shift-command-period is a handy toggle for hidden file display, it can be easier than navigating in the terminal.

Navigation

[0] Message Index

[*] Previous page

Go to full version