Forum > Debugger

Debug run fails with QT5 widgets[SOLVED]

(1/2) > >>

This may be some kind of settings problem that I do not understand:

System Fedora 35, Glibc 2.34

If I open same project with Lazarus as before and set widget type to QT5 (as before) and start debug run with F9
program never appears to screen. Green arrow button turns gray and square red stop button turns red in toolbar.
Also "ps ax" in console shows that program is running.
But it can not be seen on any desktop. And there are no errors what you can see if you try to start graphics program from text only console linux. So it is getting the graphics somewhere, but not the right display.

If I switch widgets type to GTK2 program opens visible when started from F9.
Both widgets worked before and I have feeling that this started when I updated Fedora and got Glibc 2.34

As they worked before and both qt5pas and qt5pas-devel are not touched I wonder what should I adjust to make debugged program to use display again.

What happens if you use gdb from console ? gdb ./myapplication and then type run in gdb console ?

Please check in your "Tools > Options > Debugger > Backend" if gdb or fpdebug is selected.
Please try both, and report if either works / which one(s) fail.

Open the IDE from a console, and "run" with the failing selection(s).
If the IDE prints any output to the console, please copy and paste here.

I am not seeing any Qt5 display issues with either debugger.

If its an update to Fedora issue, I'd logout and try see if you still have an option to log back in again without using Wayland.

There are also some CLI switches you can use to a QT5 app that makes it interact with Wayland differently, don't remember details I'm afraid.


I had the same thing last week on Fedora (btw: it eventually started after a *long* period). Few days later, after a 'dnf update' it worked again.

So try to install the Fedora-updates, it might help.


[0] Message Index

[#] Next page

Go to full version