Forum > QT

Lazarus 2.2.0

(1/1)

ChrisR:
Does anyone know when Debian will upgrade the package from 2.0.12 to 2.2.0?
  https://packages.debian.org/sid/devel/lazarus
While my project compiles with 2.0.12, the QT5 widgetset (and older libqt5pas) floods the console with a lot of messages
   QWidget::paintEngine: Should no longer be called
This is fixed in the recent Lazarus release
  https://gitlab.com/freepascal.org/lazarus/lazarus/-/issues/36342
GTK2 is getting pretty long in the tooth, and the latest Lazarus seems to do a great job with QT5. It would be great to have the latest version of Lazarus available for building Debian packages.

dbannon:
It will not be very quick. They have a lot going on at present.

And they like to break down the distribution to a number of smaller units so there is a fair bit of work to be done.

When its done, it will spend a few days in unstable then, hopefully, migrate into Testing. It will not migrate to Bullseye so unless you are using Testing as your distro of choice, you will not see it for close to two years. 

Its possible, but quite unlikely that L2.2 will make it to backports, they have some pretty strict rules about what goes into backports and just normal progress probably won't qualify.

On the other hand, once L2.2 is in Testing, distros like Ubuntu that release far more often will pick it up.

Davo

af0815:
Another choice is, to use the deb-packages for FPC  & Lazarus from the FPC/Lazarus Team. Downloadlink is on the left side of the forum.

dbannon:

lazarus_2.2.0+dfsg-3_source.changes ACCEPTED into unstable

Format: 1.8
Date: Mon, 17 Jan 2022 21:00:38 +0100
Source: lazarus
Architecture: source
Version: 2.2.0+dfsg-3
Distribution: unstable
Urgency: medium
Maintainer: Pascal Packaging Team <pkg-pascal-devel@lists.alioth.debian.org>
Changed-By: Abou Al Montacir <abou.almontacir@sfr.fr>
Changes:
 lazarus (2.2.0+dfsg-3) unstable; urgency=medium
 .
   * Updated control file for new Lazarus version (2.2.0).

Navigation

[0] Message Index

Go to full version