Forum > Debugger

Debugger Warning after upgrade to 2.2.0

<< < (2/2)

Martin_fr:
Go to menu: Tools > Options
Then: Debugger > Backend

Check if the entry is already in the drop down. (part of the toolbar on top).

If not, "add" a new entry, and select "FpDebug ..." as type

bobonwhidbey:
I added and selected the only FpDebug option "FpDebug internal Dwarf-debugger"

When I tried to compile, I got the attached choice. What's the choice I should choose?


ccrause:

--- Quote from: bobonwhidbey on January 10, 2022, 04:38:32 am ---I added and selected the only FpDebug option "FpDebug internal Dwarf-debugger"

When I tried to compile, I got the attached choice. What's the choice I should choose?

--- End quote ---

All the options are in principle valid choices.  My preference is to select Enable Dwarf 3.

Martin_fr:
For most people  "Dwarf 3" will get the best results (when using FpDebug).

If you go back to "gdb" this setting is kept (this is for each project / each project has its own setting).
"gdb" can use "dwarf 3", but gdb may crash with this setting. So for "gdb" it is recommended to use "dwarf with sets".

If you switch a lot between GDB and FpDebug, you may chose to use "dwarf with sets". FpDebug works well with that too (but all Locals / stack / etc will be upper-cased).

Also currently, if you debug code with "variant" variables, you need "dwarf with sets", even with FpDebug.

Navigation

[0] Message Index

[*] Previous page

Go to full version