Forum > Linux

cannot install Lazarus deb

<< < (2/2)

dbannon:

--- Quote from: aaronpeacock on December 25, 2021, 02:10:08 am ---libgdk2.0-dev
libgdk-pixbuf2.0-dev


--- End quote ---

Hmm, they should be, themseleves, dependencies of libgtk2.0-dev - did you install libgtk2.0-dev ?  Or did I send you a link too far down the page ??

Davo

af0815:
see https://wiki.freepascal.org/How_to_setup_a_FPC_and_Lazarus_Ubuntu_repository


--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---sudo apt-get install libgtk2.0-dev libgtk1.2-dev libgdk-pixbuf-dev libgpmg1-dev fakeroot libncurses5-dev

MarkMLl:

--- Quote from: dbannon on December 25, 2021, 07:39:42 am ---Hmm, they should be, themseleves, dependencies of libgtk2.0-dev - did you install libgtk2.0-dev ?  Or did I send you a link too far down the page ??

--- End quote ---

I agree, that's the important one for Lazarus (built for gtk v2, which is still the safest default). I've got notes that show that those two were required separately for GTK v1, so reading older material and extrapolating could potentially cause confusion :-)

For FPC something like libncurses5-dev, libncursesw5-dev and possibly libgpm-dev are needed.

There's other stuff worth adding as well: development packages for USB and database access etc. But these are definitely not mandatory.

MarkMLl

dbannon:
yes, we try and have just whats needed mentioned on the wiki. If you wish to use other libraries in your particular app, then you should understand you need to dev libraries for that too.  For example, I use libnotify so I need libnotify-dev.

af0815, your list does puzzle me a bit, are these things that need to be added to the wiki ?

* libgtk2.0-dev - is mentioned on the wiki.
* libgtk1.2-dev - GTK 1 ?
* libgdk-pixbuf-dev - is a dependency of libgtk2.0-dev
* libgpmg1-dev - do you mean libgpm-dev ? 
* fakeroot - only if building, eg, deb packages
* libncurses5-dev - not needed for Lazarus apps.

Davo


Navigation

[0] Message Index

[*] Previous page

Go to full version