Recent

Author Topic: cannot install Lazarus deb  (Read 5023 times)

aaronpeacock

  • Newbie
  • Posts: 3
cannot install Lazarus deb
« on: December 24, 2021, 08:29:43 pm »
So, https://sourceforge.net/projects/lazarus/files/Lazarus%20Linux%20amd64%20DEB/Lazarus%202.0.12/
has an old FPC that won't work with the very same Lazarus version it is sitting next to. Lazarus deb complains that it can't find fpc >= 3.2.2 and the sourceforge has fpc-laz_3.2.0-1_amd64.deb
which is too old.

no problem, i build fpc from install.sh and it is in /usr/local/lib/fpc but i also symlink to /usr/lib/fpc
(the installer asked if i wanted /usr/local or just /usr)

lazarus-project_2.2.0RC1-0_amd64.deb does not see it and refuses to install...


aaronpeacock

  • Newbie
  • Posts: 3
Re: cannot install Lazarus deb
« Reply #1 on: December 24, 2021, 09:35:04 pm »
building from source from handy git repo mirror with handy build scripts works OK:  https://github.com/alrieckert/lazarus

I will see where in Lazarus i must configure fpc paths and will be ok.

just mentioning that current fpc version next to lazarus installer on sourceforge is incorrect for the lazarus ide sitting next to it with instructions that you need all files, but files are wrong.

MarkMLl

  • Hero Member
  • *****
  • Posts: 4505
Re: cannot install Lazarus deb
« Reply #2 on: December 24, 2021, 10:07:28 pm »
Generally speaking I install FPC from the freepascal.org release and then build Lazarus from source and find it painless.

MarkMLl
MT+86 & Turbo Pascal v1 on CCP/M-86, multitasking with LAN & graphics in 128Kb.
Pet hate: people who boast about the size and sophistication of their computer.
GitHub repositories: https://github.com/MarkMLl?tab=repositories

dbannon

  • Hero Member
  • *****
  • Posts: 2045
    • tomboy-ng, a rewrite of the classic Tomboy
Re: cannot install Lazarus deb
« Reply #3 on: December 24, 2021, 10:29:59 pm »

https://wiki.freepascal.org/Installing_Lazarus_on_Linux#Get_the_Lazarus_Source

Installing Lazarus from source is easy, reliable and is generally a better model IMHO.

Davo
Lazarus 2, Linux (and reluctantly Win10, OSX)
My Project - https://github.com/tomboy-notes/tomboy-ng

aaronpeacock

  • Newbie
  • Posts: 3
Re: cannot install Lazarus deb
« Reply #4 on: December 25, 2021, 02:10:08 am »
ok, thank you for the link and information.

because of initial problem building:
/usr/bin/ld: cannot find -lgdk-x11-2.0
/usr/bin/ld: cannot find -lgtk-x11-2.0

I thought to add two more "linux dependencies" for the wiki:

libgdk2.0-dev
libgdk-pixbuf2.0-dev

(I have ubuntu 20.04)

should I make a wiki account to do this? MarkMLI

dbannon

  • Hero Member
  • *****
  • Posts: 2045
    • tomboy-ng, a rewrite of the classic Tomboy
Re: cannot install Lazarus deb
« Reply #5 on: December 25, 2021, 07:39:42 am »
libgdk2.0-dev
libgdk-pixbuf2.0-dev


Hmm, they should be, themseleves, dependencies of libgtk2.0-dev - did you install libgtk2.0-dev ?  Or did I send you a link too far down the page ??

Davo
Lazarus 2, Linux (and reluctantly Win10, OSX)
My Project - https://github.com/tomboy-notes/tomboy-ng

af0815

  • Hero Member
  • *****
  • Posts: 952
Re: cannot install Lazarus deb
« Reply #6 on: December 25, 2021, 09:18:51 am »
see https://wiki.freepascal.org/How_to_setup_a_FPC_and_Lazarus_Ubuntu_repository

Code: Pascal  [Select][+][-]
  1. sudo apt-get install libgtk2.0-dev libgtk1.2-dev libgdk-pixbuf-dev libgpmg1-dev fakeroot libncurses5-dev
regards
Andreas

MarkMLl

  • Hero Member
  • *****
  • Posts: 4505
Re: cannot install Lazarus deb
« Reply #7 on: December 25, 2021, 09:29:46 am »
Hmm, they should be, themseleves, dependencies of libgtk2.0-dev - did you install libgtk2.0-dev ?  Or did I send you a link too far down the page ??

I agree, that's the important one for Lazarus (built for gtk v2, which is still the safest default). I've got notes that show that those two were required separately for GTK v1, so reading older material and extrapolating could potentially cause confusion :-)

For FPC something like libncurses5-dev, libncursesw5-dev and possibly libgpm-dev are needed.

There's other stuff worth adding as well: development packages for USB and database access etc. But these are definitely not mandatory.

MarkMLl
MT+86 & Turbo Pascal v1 on CCP/M-86, multitasking with LAN & graphics in 128Kb.
Pet hate: people who boast about the size and sophistication of their computer.
GitHub repositories: https://github.com/MarkMLl?tab=repositories

dbannon

  • Hero Member
  • *****
  • Posts: 2045
    • tomboy-ng, a rewrite of the classic Tomboy
Re: cannot install Lazarus deb
« Reply #8 on: December 25, 2021, 09:51:38 am »
yes, we try and have just whats needed mentioned on the wiki. If you wish to use other libraries in your particular app, then you should understand you need to dev libraries for that too.  For example, I use libnotify so I need libnotify-dev.

af0815, your list does puzzle me a bit, are these things that need to be added to the wiki ?

* libgtk2.0-dev - is mentioned on the wiki.
* libgtk1.2-dev - GTK 1 ?
* libgdk-pixbuf-dev - is a dependency of libgtk2.0-dev
* libgpmg1-dev - do you mean libgpm-dev ? 
* fakeroot - only if building, eg, deb packages
* libncurses5-dev - not needed for Lazarus apps.

Davo


Lazarus 2, Linux (and reluctantly Win10, OSX)
My Project - https://github.com/tomboy-notes/tomboy-ng

 

TinyPortal © 2005-2018