Forum > Windows (32/64)

Execution stopped - but why?

(1/2) > >>

Greetings All

I have installed and use Lazarus 2.0.12 on a Windows 10 PC.  No issues.  I have written graphical programmes and command line programmes.

Recently, I installed the same version of Lazarus on a laptop that has Windows 10.  I copied over the project folders.

But most command line programmes do not work now.  All graphical programmes do not work.

Both types fail in the same way:  They compile (Ctrl + F9).  But after pressing Run (F9) the next event is the pop up message:  "Execution Stopped".  No other helpful messages.

I went looking at some of the settings, not that I understand much about these things, but I like trying.  The laptop had this setting:
  Tools > Options > Files > FPC source directory was: "$(LazarusDir)fpc$(FPCVer)source"
The PC had this setting:
  Tools > Options > Files > FPC source directory was: "C:\lazarus\fpc\3.2.0\source"

I made the laptop the same as the PC.  I also checked both machines and the path/folder was present.  But it did not fix the problem.

There is one other difference.  It is with the Tools > Options > Files > Compiler Executable:
      PC = "fpc.exe"
Laptop = "C:\Lazarus\fpc\3.2.0\bin\x86_64-win64\fpc.exe"
I have checked and the Compiler Executable path/folder/file is present on both machines

But that is it.  I am at the edge of my knowledge

Any help appreciated

Is your laptop a 64-bit Windows?


First of all: Do they work outside the debugger?
- menu Run > run without debugger.
- or compile, then find the exe, and run outside the IDE.

Also, do they run if compiled with optimization off? (level 0 / -O- )

The difference in files, might be if your desktop was an upgrade from an older version of Lazarus.

The "sources" seem to have resolved to the same real path, since replacing them worked.

About the compiler exe. Here the question is, if you have another fpc somewhere on your desktop
Menu: View > Ide Internals > About FPC
  There will be (somewhere in the middle)
     FPC executable:
or similar.

Dear All

Thanks for the feedback

Both machines are 64 bit

The PC has freepascal on it
the laptop does not

Run without debugging does nothing.  No message of any type are output.

Both were fresh install of Windows 10

I tried to make an executable. Clicked  Run > Build (Shift + F9).  I closed Lazarus and browsed to the executable.  I double clicked it, however, the pop up message was:
   "The application was able to start correctly
    (0x00000007b) Click OK to close the application"

I have no idea what:
  "Also, do they run if compiled with optimization off? (level 0 / -O- )"

Any further help appreciated

What about your virus scanner? Virus scanners are evil today in particular when they call themselves "intelligent". I had a similar case with BitDefender which after an update to an "intelligent" feature deleted my entire FPC tool chain. In the end I unstalled BitDefender in spite of my running valid license, and am using the Defender which comes with Windows 10/11. So far, it has been less aggressive, and I never had such issues as with BitDefender. But even with Defender, it is highly recommended to put Lazarus, FPC and project directories on the whitelist of the scanner.


[0] Message Index

[#] Next page

Go to full version