Recent

Author Topic: [Fixed]Can no longer update Trunk do to Fpdebug changes from Joost Van Der Sluis  (Read 3435 times)

jamie

  • Hero Member
  • *****
  • Posts: 4583
As of 12/13 to today I can't update my local copy using those files modified by said DEV.

 I did notice there was a commit made to correct a windows compiling issue but all that did was move the error to the LazDebugger indicating "Wrong number of Parameters" in a call.

 Prior to that, it could not locate a function .

 I have reverted etc and retried, no go.

 I am on Win10 Laz 64 using 3.2.0 fpc with the trunk.

 Am I the only one having this problem with the trunk?
« Last Edit: December 15, 2021, 02:32:26 am by jamie »
The only true wisdom is knowing you know nothing

AlexTP

  • Hero Member
  • *****
  • Posts: 1776
    • UVviewsoft
Re: Can no longer update Trunk do to Fpdebug changes from Joost Van Der Sluis
« Reply #1 on: December 14, 2021, 11:26:31 pm »
I have it too.

wp

  • Hero Member
  • *****
  • Posts: 9606
Re: Can no longer update Trunk do to Fpdebug changes from Joost Van Der Sluis
« Reply #2 on: December 14, 2021, 11:46:29 pm »
Such things happen...

Normally you do not need the very latest commit. Therefore, you should use git to return to an older revision and do a clean rebuild of the IDE. If it does not work either, go back another few days. I don't understand why this is not working for you (it did for me since I noticed this issue yesterday).
Mainly Lazarus trunk / fpc 3.2.0 / all 32-bit on Win-10, but many more...

Josh

  • Hero Member
  • *****
  • Posts: 932
Re: Can no longer update Trunk do to Fpdebug changes from Joost Van Der Sluis
« Reply #3 on: December 15, 2021, 12:10:28 am »
same here. win 64, trunk fpc and laz

Code: [Select]
leakview\leakinfo.pas(899,56) Error: (3026) Wrong number of parameters specified for call to "Create"
fpdebug\lib\x86_64-win64\fpdbgloader.ppu:fpdbgloader.pp(156,33) Error: (5088) Found declaration: constructor Create(Boolean;TDBGPtr);
leakview\leakinfo.pas(1123) Fatal: (10026) There were 2 errors compiling module, stopping
Fatal: (1018) Compilation aborted
« Last Edit: December 15, 2021, 12:17:09 am by josh »
Development Installation Lazarus 1.3, FPC 2.7.1,Windows 7/8 32/64, OSX, *nix

Test Environment Lazarus & FPC Trunk on Windows and OSX (Cocoa Mainly on OSX). Testing also Crosscompile windows to OSX.. 
Any posts made from 2015 will be based on Lazarus Trunk.

trev

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1989
  • Former Delphi 1-7, 10.2 user
Re: Can no longer update Trunk do to Fpdebug changes from Joost Van Der Sluis
« Reply #4 on: December 15, 2021, 12:20:31 am »
No problem with Lazarus trunk 64 bit on macOS compiled with FPC trunk from 2021-12-02.
Lazarus 2.3, FPC 3.3.1 macOS 12.3.1 x86_64 Xcode 13.4
Lazarus 2.3, FPC 3.3.1 macOS 12.3.1 aarch64 Xcode 13.4

dsiders

  • Hero Member
  • *****
  • Posts: 637
Re: Can no longer update Trunk do to Fpdebug changes from Joost Van Der Sluis
« Reply #5 on: December 15, 2021, 01:34:14 am »
Build errors were resolved in commit 8205a04199. Confirmed for Windows 64-bit.
Lazarus 2.0.12, 2.2.0, 2.2.2, 2.3.0 (Git) / FPC 3.2.0, 3.2.2, 3.3.1 / x86 64-bit / Windows 8.1
Preview Lazarus 2.3.0 documentation at: https://dsiders.gitlab.io/lazdocsnext

jamie

  • Hero Member
  • *****
  • Posts: 4583
Re: Can no longer update Trunk do to Fpdebug changes from Joost Van Der Sluis
« Reply #6 on: December 15, 2021, 02:32:02 am »
confirmed.
Thanks, I'll try to mark as solved.



The only true wisdom is knowing you know nothing

 

TinyPortal © 2005-2018