Forum > OpenGL

Strange issue with GLScene

<< < (2/3) > >>

So, if you copy compiled program from laptop then it works fine?
And if you compile program on desktop computer then it doesn't work?

Try to run program compiled on desktop computer directly (outside of Lazarus) - to exclude debugger.
Try to copy program from desktop computer to laptop and see if it works.
Do you have exactly same version of Lazarus, FPC, packages, ... installed in both computers?

Running desktop compiled program directly from disk have same error.
Running desktop compiled program on laptop, same error.

Lazarus on laptop:
Version: 2.0.10
FPC Version: 3.2.0
SVN Revision: 63526

Lazarus on desktop:
Version: 2.0.12
FPC Version: 3.2.0
SVN Revision: 64642

Well, it looks like some environment issue on desktop computer.
Do you have exactly the same library on desktop computer as in the laptop?
Did you copy project from laptop to desktop computer or did you make new project on desktop computer?
You could try to install same Lazarus version on desktop computer as you have in laptop.

Also, as someone mentioned, you should make minimal demo project that shows issue.

As I wrote in my first reply I tried one of the GLScene examples on desktop as well as on laptop and the the issue remained.

Also tried installing version 2.0.10 on desktop and still same error %)

Do you compile on both computers to 32-bit or 64-bit?
Do you have exactly the same library on desktop computer as in the laptop?


[0] Message Index

[#] Next page

[*] Previous page

Go to full version