Forum > OpenGL

Strange issue with GLScene

(1/3) > >>

stab:
On a laptop I've made an app where I can display a 3D-model, rotate
it and zoom in and out using a GLSceneViewer and GLScene with
a GLDummyCube, a GLHeightField, GLCamera and a GLLigthSource.
When I installed the code on a personal computer with more power
and ram, 3D-models doesn't show up as before even though I haven't
changed the code.
Rotations is preformed buy left mouse button down and move on the
laptop.
When I load a 3D-model on the personal computer it doesn't show up
at all, but when trying to rotate it, I can see it flashing in the
GLSceneViewer. When I move the program window a little outside the
screen and back again, the model is seen, but immediately as the mouse
is moved whithin the program window it disappears again.

I guess there is something real simple I've done wrong, but can't
figure it out :o.

Any hint appreciated

My system:
Windows 10 64-bit
Ram: 24 GB

Lazarus 2.0.12
FPC Version: 3.2.0
SVN Revision: 64642

Regards
stab

Ñuño_Martínez:
Hard to know without code.  Since it is a simple project maybe you can attach it.

stab:
I order to further check the issue I tried example Fuente, both at my laptop and the personal computer and experience the same behavior.
On the laptop Fuente runs fine displaying kind of a fountain of particles. On the personal computer it is just flashing like in my own program

Could it possible be caused by some parameter setting in the cadencer running in 4.00 GHz in contrast to the laptop running only 2.20 GHz? :o

Handoko:
Could it be hardware/driver issue? Maybe you can try to run Castle Game Engine demos or play real 3D games on the machine.

https://wiki.lazarus.freepascal.org/Castle_Game_Engine

stab:
I even copied the program that was compiled and worked on the laptop to the other computer and it ran OK there. That would exclude hardware/driver issue or?

Navigation

[0] Message Index

[#] Next page

Go to full version