Recent

Author Topic: OnMouseMove/OnMouveLeave not working correctly on Linux  (Read 3295 times)

Gald

  • Jr. Member
  • **
  • Posts: 85
OnMouseMove/OnMouveLeave not working correctly on Linux
« on: December 02, 2021, 03:19:57 am »
On Windows it works as expected, but not on Linux. I tried Manjaro and Mint.

How to:

1- Execute de App.
2- Move your mouse between the panels as fast as you can.
3- Do not take your mouse off the Form (it's kind of a game to identify the problem).
4- Try to do what I did on the related pic.

Only ONE Panel should be Green.
« Last Edit: December 02, 2021, 04:19:00 am by Gald »
Lazarus 2.0.12 r64642 FPC 3.2.0 x86_64-win64-win32/win64/Manjaro KDE 21
AMD Ryzen 3 1300X Quad-Core Processor 3.50 GHz / 8,00 GB RAM / GTX 1500 TI / 2TB M.2 NVMe

Handoko

  • Hero Member
  • *****
  • Posts: 4520
  • My goal: build my own game engine using Lazarus

Gald

  • Jr. Member
  • **
  • Posts: 85
Re: OnMouseMove/OnMouveLeave not working correctly on Linux
« Reply #2 on: December 02, 2021, 06:22:22 am »
Same issue has been reported:
https://forum.lazarus.freepascal.org/index.php/topic,37050.msg247726.html#msg247726

Ow, this is so sad!
Do you know if this applies on button components made of TPanels too?
I have many plans to build my own components based on TPanels.
« Last Edit: December 02, 2021, 06:26:13 am by Gald »
Lazarus 2.0.12 r64642 FPC 3.2.0 x86_64-win64-win32/win64/Manjaro KDE 21
AMD Ryzen 3 1300X Quad-Core Processor 3.50 GHz / 8,00 GB RAM / GTX 1500 TI / 2TB M.2 NVMe

Handoko

  • Hero Member
  • *****
  • Posts: 4520
  • My goal: build my own game engine using Lazarus
Re: OnMouseMove/OnMouveLeave not working correctly on Linux
« Reply #3 on: December 02, 2021, 08:03:57 am »
I tested the issue on TForm, TStringGrid, TButton, TShape, TToolbar, TImage, the problem was reproducible on all of them if I run  the code on Linux GTK2. So I believe the bug is in their ancestor class. Button components made of TPanel, I think they will have the same issue too.

I have a workaround for it, not nice but that works:
https://forum.lazarus.freepascal.org/index.php/topic,37050.msg388249.html#msg388249
« Last Edit: December 02, 2021, 08:23:45 am by Handoko »

Gald

  • Jr. Member
  • **
  • Posts: 85
Re: OnMouseMove/OnMouveLeave not working correctly on Linux
« Reply #4 on: December 02, 2021, 08:51:16 am »
Oh, i see...

Thanks, Handoko!
Lazarus 2.0.12 r64642 FPC 3.2.0 x86_64-win64-win32/win64/Manjaro KDE 21
AMD Ryzen 3 1300X Quad-Core Processor 3.50 GHz / 8,00 GB RAM / GTX 1500 TI / 2TB M.2 NVMe

 

TinyPortal © 2005-2018