Recent

Author Topic: Failed PPU-file 87  (Read 1917 times)

edgarrod71

  • New Member
  • *
  • Posts: 26
Failed PPU-file 87
« on: November 23, 2021, 05:53:37 am »
I installed Lazarus on my old Mac, upgraded to Catalina and it couldn't compile, showed a message like:
lcltype.pp(18,42) Fatal: Invalid PPU-File entry: 87

I modified manually the file deleting the consecutive brackets

}

{

then, I tried to compile again and this new error appeared:

laz_avl_tree.pp(33,24) Fatal: Invalid PPU-File entry: 87

deleted a pair of brackets, reinserted them the same way and next error was:

lazutf8.pas(17,58) Fatal: Invalid PPU-File entry: 87

... next ...

fpcadds.pas(37,6) Fatal: Invalid PPU-File entry: 87

seems that there is a bad Tab inserted or some hidden character on every file.

... after 30 more dumbie characters to correct ...

lookupstringlist.pas(23,44) Fatal: Invalid PPU-File entry: 87

... and ...

more painful hidden char finding...

Later, I opened a terminal, listed the files in /Applications/Lazarus/components and all belonged to Macports:Admin, so I changed to my user like this:

$ sudo chown -R edgarrod:admin /Applications/Lazarus/components

changed also the +w option with

$ sudo chmod -R +w /Applications/Lazarus/components

and the same with

$ sudo chown -R edgarrod:admin /Applications/Lazarus/packager
$ sudo chmod -R +w /Applications/Lazarus/packager

and voilà, it compiled at last, but I couldn't make a clean compile of Lazarus yet.

trev

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1799
  • Former Delphi 1-7, 10.2 user
Re: Failed PPU-file 87
« Reply #1 on: November 23, 2021, 06:36:14 am »
Depending on which version of macOS you upgraded you Catalina, it may just be easier to delete the current installation (see Uninstalling Lazarus on macOS) and reinstall from scratch (see Installing Lazarus on macOS).

Also, be aware that when you upgrade macOS, any existing command line tool installation is deleted in the process.
Lazarus 2.3, FPC 3.3.1 macOS 12.1 x86_64 Xcode 13.2
Lazarus 2.3, FPC 3.3.1 macOS 12.1 aarch64 Xcode 13.2
Lazarus 2.3, FPC 3.2.2 FreeBSD 13.0 amd64 VM
Lazarus 2.3, FPC 3.2.2 FreeBSD 12.2 amd64 VM
Lazarus 2.1 r61574 FPC 3.0.4 Ubuntu 20.04 VM
Lazarus 2.0.10 FPC 3.2.0 Win10 amd64 VM

ccrause

  • Hero Member
  • *****
  • Posts: 527
Re: Failed PPU-file 87
« Reply #2 on: November 23, 2021, 06:53:25 am »
I installed Lazarus on my old Mac, upgraded to Catalina and it couldn't compile, showed a message like:
lcltype.pp(18,42) Fatal: Invalid PPU-File entry: 87
Just a guess, sounds like the compiler version is different to the one used to generate the installed units. Modifying the source could then leads to a recompile of thar file.

So @trev's suggestion is probably the easiest way out of the mess.

edgarrod71

  • New Member
  • *
  • Posts: 26
Re: Failed PPU-file 87
« Reply #3 on: November 23, 2021, 07:01:26 pm »
No, the version is ok.  It's simply some corrupted files that have an invisible ASCII character inside, I had to use nano to find the place where it had the error, sometimes deleted the word or brackets or space and all errors were gone.

I had to put -Recursively to let all files like components and register to be writable and changed the owner to my user, and it finally worked, it let me compile the projects.

After that, I recompiled Lazarus and it worked too.

I tried to change Laz IDE to be dockable but when I try to start lazarus again it simply doesn't open with an error like this:

LSOpenURLsWithRole() failed for the application /Volumes/edgarrod71/.lazarus/bin/lazarus.app with error -10810.

I started to be frustrated, but I found a copy of the old lazarus before compilation and restored it, and voilà again, it works.  I tried to uninstall the dockable units.  I wish to work with it with docks or Spartan units.

Any help?
 

 

TinyPortal © 2005-2018