Forum > Other

Freebsd 13 and Freebsd 12 Fascgi

(1/1)

nick1965:
Two Questions

On freebsd 13 lxde i try everything to install lazarus ( both gtk-2 and qt5 )
After install each time i try to install weblaz 1.0   i get error  JSTREE not found.
any solution on this?

Second Question.
On freebsd 12
I create a simple Fastcgi hello world
when i request the page i get error 

--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---project1 raised exception class "Unknown" with messageNot Supported on GDB < 5.3 
Any help?

trev:

--- Code: ---[quote author=nick1965 link=topic=57230.msg425434#msg425434 date=1637313885]
On freebsd 13 lxde i try everything to install lazarus ( both gtk-2 and qt5 )
After install each time i try to install weblaz 1.0   i get error  JSTREE not found.
any solution on this?
--- End code ---

I just installed weblaz on 13.0-RELEASE-p4 GENERIC amd64 GTK2 without any issues.

Lazarus version: 2.3.0
Lazarus revision: main-2_3-685-g3891f57067
Lazarus build date: 2021/11/19
Lazarus was compiled for x86_64-freebsd
Lazarus was compiled with FPC 3.2.2

nick1965:
well
iits a clean install
installed from pkg system and 100% is not works
and the message is weblaz cannot find JStree

in freebsd 12 tehre is not this problem .

mine it says

Lazarus version #: 2.0.12
FPC Version: 3.2.2
SVN Version:  Unknown
x86 64-freebsd-gtk2

and does not works

trev:
jstree is part of FPC:


--- Code: ---[/home/trev] $ locate -i jstree
/usr/local/lib/fpc/3.2.0/units/x86_64-freebsd/fcl-js/jstree.o
/usr/local/lib/fpc/3.2.0/units/x86_64-freebsd/fcl-js/jstree.ppu
/usr/local/lib/fpc/3.2.2/units/x86_64-freebsd/fcl-js/jstree.o
/usr/local/lib/fpc/3.2.2/units/x86_64-freebsd/fcl-js/jstree.ppu
/usr/local/share/fpc/3.0.4/packages/fcl-js/src/jstree.pp
/usr/local/share/fpc/3.2.0/packages/fcl-js/src/jstree.pp
/usr/local/share/fpc/3.2.2/packages/fcl-js/src/jstree.pp
--- End code ---

You should have it unless your FPC install is faulty.

nick1965:

I installed freebsd13 + lxde
Then i try to install  editors/lazarus-qt5 with pkg
After install i try to add weblaz for my fastcgi app.
Not success
Then i remove ( with pkg ) the qt5 version and i installed simple editors/lazarus
Same problem
Then i try with ports

probably everything is messed Up ...

i will try to reinstall everything again without try the qt5


Thanks anyway.



Navigation

[0] Message Index

Go to full version