Recent

Author Topic: Strange behaviour of SQLdb Component  (Read 674 times)

incendio

  • Full Member
  • ***
  • Posts: 126
Strange behaviour of SQLdb Component
« on: November 18, 2021, 03:57:14 am »
Hi guys,

Long time ago, I build a simple Windows app using TSQLConnector, TSQLTransaction, TSQLQuery, & TDatasource, with Firebird 3 database, and Lazarus 64 bit( forgot the version).

I didn't install Firebird 3 database in that machine that runs the app, and app runs OK, until a couple days ago.

A couple days ago, app runs with error, something like :

Couldn't load gds32.dll or fbclient.dll.

So, I rebuild again the app using Lazarus 2.0.12.64 bit and install Firebird 3.06 64 bit on that machine.

Usually, this approach solve the problem (I have tried it to other machine & it worked OK), but this time, it didn't. Same error still occurred.

Others app that using Firebird, such as Flamerobin, runs OK without any problem.

So I changed all components in the app that using build in TSQL* to IBX, compiled again the app and supplied fbclient.dll to the same directory with my app and it runs OK.

I think, from now on, I will not using TSQL* again and  will switch to IBX.

 

TinyPortal © 2005-2018