Forum > Linux

Error while linking

<< < (2/3) > >>

ChPr:

--- Quote from: Zvoni on November 15, 2021, 11:40:26 am ---IPv6?

--- End quote ---

Yes, but what do to correct this ?

Sincerely.

Pierre.

trev:
Perhaps sudo apt -o Acquire::ForceIPv4=true --fix-broken install

ChPr:

--- Quote from: trev on November 15, 2021, 12:06:26 pm ---Perhaps sudo apt -o Acquire::ForceIPv4=true --fix-broken install

--- End quote ---

Thank you for this idea. The resut is :


--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---pi@raspberrypi:~ $  sudo apt -o Acquire::ForceIPv4=true --fix-broken installLecture des listes de paquets... FaitConstruction de l'arbre des dépendancesLecture des informations d'état... FaitCorrection des dépendances... FaitLes paquets supplémentaires suivants seront installés :  autoconf automake autopoint autotools-dev debhelper dh-autoreconf dh-strip-nondeterminism dwz gettext gir1.2-gtk-2.0 gir1.2-harfbuzz-0.0 icu-devtools  intltool-debian libarchive-cpio-perl libarchive-zip-perl libatk1.0-dev libblkid-dev libcairo-script-interpreter2 libcairo2-dev libffi-dev  libfile-stripnondeterminism-perl libfontconfig1-dev libfribidi-dev libgdk-pixbuf2.0-bin libgdk-pixbuf2.0-dev libglib2.0-dev libglib2.0-dev-bin  libgraphite2-dev libgtk2.0-dev libharfbuzz-dev libharfbuzz-gobject0 libicu-dev libltdl-dev liblzo2-2 libmail-sendmail-perl libmount-dev libpango1.0-dev  libpcre16-3 libpcre3-dev libpcre32-3 libpcrecpp0v5 libpixman-1-dev libselinux1-dev libsepol1-dev libsigsegv2 libsys-hostname-long-perl libtool  libxcb-render0-dev libxcb-shm0-dev libxcomposite-dev libxcursor-dev libxdamage-dev libxext-dev libxfixes-dev libxft-dev libxi-dev libxinerama-dev  libxml2-utils libxrandr-dev libxrender-dev m4 pango1.0-tools po-debconf x11proto-composite-dev x11proto-damage-dev x11proto-fixes-dev x11proto-input-dev  x11proto-randr-dev x11proto-xext-dev x11proto-xinerama-devPaquets suggérés :  autoconf-archive gnu-standards autoconf-doc dh-make gettext-doc libasprintf-dev libgettextpo-dev libcairo2-doc libglib2.0-doc libgraphite2-utils  libgtk2.0-doc icu-doc libtool-doc imagemagick libpango1.0-doc gfortran | fortran95-compiler gcj-jdk libxext-doc m4-doc libmail-box-perlLes NOUVEAUX paquets suivants seront installés :  autoconf automake autopoint autotools-dev debhelper dh-autoreconf dh-strip-nondeterminism dwz gettext gir1.2-gtk-2.0 gir1.2-harfbuzz-0.0 icu-devtools  intltool-debian libarchive-cpio-perl libarchive-zip-perl libatk1.0-dev libblkid-dev libcairo-script-interpreter2 libcairo2-dev libffi-dev  libfile-stripnondeterminism-perl libfontconfig1-dev libfribidi-dev libgdk-pixbuf2.0-bin libgdk-pixbuf2.0-dev libglib2.0-dev libglib2.0-dev-bin  libgraphite2-dev libgtk2.0-dev libharfbuzz-dev libharfbuzz-gobject0 libicu-dev libltdl-dev liblzo2-2 libmail-sendmail-perl libmount-dev libpango1.0-dev  libpcre16-3 libpcre3-dev libpcre32-3 libpcrecpp0v5 libpixman-1-dev libselinux1-dev libsepol1-dev libsigsegv2 libsys-hostname-long-perl libtool  libxcb-render0-dev libxcb-shm0-dev libxcomposite-dev libxcursor-dev libxdamage-dev libxext-dev libxfixes-dev libxft-dev libxi-dev libxinerama-dev  libxml2-utils libxrandr-dev libxrender-dev m4 pango1.0-tools po-debconf x11proto-composite-dev x11proto-damage-dev x11proto-fixes-dev x11proto-input-dev  x11proto-randr-dev x11proto-xext-dev x11proto-xinerama-dev0 mis à jour, 70 nouvellement installés, 0 à enlever et 0 non mis à jour.1 partiellement installés ou enlevés.Il est nécessaire de prendre 9 292 ko/27,2 Mo dans les archives.Après cette opération, 105 Mo d'espace disque supplémentaires seront utilisés.Souhaitez-vous continuer ? [O/n] oErr :1 http://raspbian.raspberrypi.org/raspbian buster/main armhf icu-devtools armhf 63.1-6  404  Not Found [IP : 93.93.128.193 80]Err :2 http://raspbian.raspberrypi.org/raspbian buster/main armhf libicu-dev armhf 63.1-6  404  Not Found [IP : 93.93.128.193 80]Err :3 http://raspbian.raspberrypi.org/raspbian buster/main armhf pango1.0-tools armhf 1.42.4-7~deb10u1  404  Not Found [IP : 93.93.128.193 80]Err :4 http://raspbian.raspberrypi.org/raspbian buster/main armhf libpango1.0-dev armhf 1.42.4-7~deb10u1  404  Not Found [IP : 93.93.128.193 80]Err :5 http://raspbian.raspberrypi.org/raspbian buster/main armhf libxml2-utils armhf 2.9.4+dfsg1-7+b3  404  Not Found [IP : 93.93.128.193 80]E: Impossible de récupérer http://raspbian.raspberrypi.org/raspbian/pool/main/i/icu/icu-devtools_63.1-6_armhf.deb  404  Not Found [IP : 93.93.128.193 80]E: Impossible de récupérer http://raspbian.raspberrypi.org/raspbian/pool/main/i/icu/libicu-dev_63.1-6_armhf.deb  404  Not Found [IP : 93.93.128.193 80]E: Impossible de récupérer http://raspbian.raspberrypi.org/raspbian/pool/main/p/pango1.0/pango1.0-tools_1.42.4-7~deb10u1_armhf.deb  404  Not Found [IP : 93.93.128.193 80]E: Impossible de récupérer http://raspbian.raspberrypi.org/raspbian/pool/main/p/pango1.0/libpango1.0-dev_1.42.4-7~deb10u1_armhf.deb  404  Not Found [IP : 93.93.128.193 80]E: Impossible de récupérer http://raspbian.raspberrypi.org/raspbian/pool/main/libx/libxml2/libxml2-utils_2.9.4+dfsg1-7+b3_armhf.deb  404  Not Found [IP : 93.93.128.193 80]E: Impossible de récupérer certaines archives, peut-être devrez-vous lancer apt-get update ou essayer avec --fix-missing ?pi@raspberrypi:~ $
Though the address are IPV4, there is alway the same problem.

Using --fix-missing gives :


--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---pi@raspberrypi:~ $ sudo apt --fix-missing installLecture des listes de paquets... FaitConstruction de l'arbre des dépendancesLecture des informations d'état... FaitVous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.Les paquets suivants contiennent des dépendances non satisfaites : lazarus-project : Dépend: libgtk2.0-dev (>= 2.6.0) mais il n'est pas installéE: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet   (ou indiquez une solution).pi@raspberrypi:~ $
Always the same problem.

Sincerely.

Pierre.

marcov:
I think it is slowly time to move this to a debian support forum. It goes beyond pascal support.

dbannon:
yes, as marcov suggests, this is not a FPC/Lazarus issue. You have a apt config problem.

You will get better diagnostic information just trying to clean up apt -


--- Code: ---sudo apt update
--- End code ---

is that works with out error, try -


--- Code: ---sudo apt upgrade
--- End code ---

If that does not get you back to a sensible apt response and allow the fix-broken to work, you need to seek help, probably on a raspberry pi forum.  Its an apt problem !

EDIT : how I know its an apt problem ?


--- Code: ---dbannon@dell:~/qemu/sparc64$ wget http://raspbian.raspberrypi.org/raspbian/pool/main/i/icu/icu-devtools_63.1-6_armhf.deb
--2021-11-15 23:14:16--  http://raspbian.raspberrypi.org/raspbian/pool/main/i/icu/icu-devtools_63.1-6_armhf.deb
Resolving raspbian.raspberrypi.org (raspbian.raspberrypi.org)... 93.93.128.193, 2a00:1098:0:80:1000:75:0:3
Connecting to raspbian.raspberrypi.org (raspbian.raspberrypi.org)|93.93.128.193|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2021-11-15 23:14:17 ERROR 404: Not Found.
--- End code ---


Davo

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version