Forum > Linux

Error while linking

<< < (3/3)

ChPr:
I would like to thank all of you because with the help of your suggestions I was able to load my missing libraries.
Before asking you, I had used apt-get, but it didn't bring any result. So it seems that apt is more appropriate for this kind of manipulation.

Thanks again to you.

Pierre.

Zvoni:

--- Quote from: dbannon on November 15, 2021, 01:21:20 pm ---
EDIT : how I know its an apt problem ?


--- Code: ---dbannon@dell:~/qemu/sparc64$ wget http://raspbian.raspberrypi.org/raspbian/pool/main/i/icu/icu-devtools_63.1-6_armhf.deb
--2021-11-15 23:14:16--  http://raspbian.raspberrypi.org/raspbian/pool/main/i/icu/icu-devtools_63.1-6_armhf.deb
Resolving raspbian.raspberrypi.org (raspbian.raspberrypi.org)... 93.93.128.193, 2a00:1098:0:80:1000:75:0:3
Connecting to raspbian.raspberrypi.org (raspbian.raspberrypi.org)|93.93.128.193|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2021-11-15 23:14:17 ERROR 404: Not Found.
--- End code ---


Davo

--- End quote ---
It's not. The file simply doesn't exist, but

not existing: icu-devtools_63.1-6_armhf.deb
exists: icu-devtools_63.1-6+deb10u1_armhf.deb
exists: icu-devtools_67.1-7_armhf.deb

http://raspbian.raspberrypi.org/raspbian/pool/main/i/icu/

dbannon:

--- Quote from: Zvoni on November 15, 2021, 03:47:37 pm ---.....
It's not. The file simply doesn't exist, but

not existing: icu-devtools_63.1-6_armhf.deb
exists: icu-devtools_63.1-6+deb10u1_armhf.deb
exists: icu-devtools_67.1-7_armhf.deb

http://raspbian.raspberrypi.org/raspbian/pool/main/i/icu/

--- End quote ---

Which is why I suggested he needed to refresh his apt cache.

@ChPr - It probably does not matter which you use, apt or apt-get, both do the same thing, apt has a slightly friendlier user interface, the older apt-get is a touch more suited to scripting.

Glad you have sorted it out.

Davo

Navigation

[0] Message Index

[*] Previous page

Go to full version