Forum > Linux

Fpc versions for Lazarus trunk?

(1/2) > >>

kapibara:
Which versions of fpc can compile Lazarus trunk currently?

dbannon:
at least 3.2.0, 3.2.2 and 3.2.3 (ie fixes).

Davo

kapibara:
Thanks. I have fpc 3.2.2 and compiling with "make bigide " failed.
(But using just "make" worked, so now I'm up and running)


--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---(9022) Compiling resource ../units/x86_64-linux/gtk2/lazarus.or(9015) Linking ../lazarus/usr/bin/ld: cannot find -lgdk-x11-2.0/usr/bin/ld: cannot find -lgtk-x11-2.0/usr/bin/ld: cannot find -lX11/usr/bin/ld: cannot find -lgdk_pixbuf-2.0/usr/bin/ld: cannot find -lgobject-2.0/usr/bin/ld: cannot find -lglib-2.0/usr/bin/ld: cannot find -lgthread-2.0/usr/bin/ld: cannot find -lgmodule-2.0/usr/bin/ld: cannot find -lpango-1.0/usr/bin/ld: cannot find -lcairo/usr/bin/ld: cannot find -latk-1.0/usr/bin/ld: cannot find -lpangocairo-1.0/home/roger/dev/lazsvn/ide/lazarus.pp(167,1) Error: (9013) Error while linking/home/roger/dev/lazsvn/ide/lazarus.pp(167,1) Fatal: (10026) There were 1 errors compiling module, stoppingFatal: (1018) Compilation abortedmake[2]: *** [Makefile:4668: lazarus] Error 1make[2]: Leaving directory '/home/roger/dev/lazsvn/ide'make[1]: *** [Makefile:5109: bigide] Error 2make[1]: Leaving directory '/home/roger/dev/lazsvn/ide'make: *** [Makefile:3738: idebig] Error 2 

Zvoni:
IIRC, those are dependencies you have to install beforehand (the "dev"-packages i think)

dbannon:

https://wiki.freepascal.org/Installing_Lazarus_on_Linux


--- Quote ---Note: Dependencies - you probably want to build the GTK2 version of Lazarus, most distros will have gtk2 preinstalled but you may need to install its dev libraries. So, install gdb, libx11-dev and libgtk2.0-dev, that will bring gtk2 itself along if necessary. If building a QT5 version, you will need libqt5pas-dev. If you are going to work with GTK3, you will need to install libgtk-3-dev
--- End quote ---

But do please read the above mentioned wiki page.

Davo

Navigation

[0] Message Index

[#] Next page

Go to full version