Forum > Debugger

[Solved] Debugger on FreeBSD

(1/2) > >>

Alextp:
Martin, I cannot use 'gdb' default debugger on freebsd, always got error on app run (the correct path to 'gdb' was set!). So I installed  2 IDE packages - 'fpdebug' and 'lazdebuggerfp'. Then I made the new debugger IDE profile and set it to use fpdebug. Then I got error msgbox (forgot the message text) on running app with debug! No success!

(I recompiled the IDE)

Martin_fr:
FpDebug only supports Windows and Linux.
I don't know the FreeBsd API for debugging, or if it similar/same to/as the Linux "ptrace". But even then, that would need to be implemented/adapted.

What error do you get with GDB?

Alextp:
gdb:
No error msg, but breakpoints (e.g. in app FormShow) are ignored, no stops. IDE options dialog is:

debugger type: gdb
path: /usr/local/bin/gdb (valid file name)
only non-default options in the listview: TimeoutForEval=-1, UseAsyncCommandMode=off, WarnOnTimeOut=on.

ccrause:
Please show all the messages from the Debug Output window, or enable debug logging and post that output.

Also read this FreeBSD note about updating an old gdb version. Not sure if that is relevant for your situation.

Alextp:
On the new app, I see the breakpoint working!
After change
- "debug info" from "external file" to "internal",
- "dwarf with sets" to 'drarf2"
problem solved!

Navigation

[0] Message Index

[#] Next page

Go to full version