Recent

Author Topic: Debian 11 contains wrong Lazarus configuration  (Read 2289 times)

kapibara

  • Hero Member
  • *****
  • Posts: 561
Debian 11 contains wrong Lazarus configuration
« on: October 30, 2021, 09:02:10 am »
After installing Debian 11 from debian-live-11.1.0-amd64-kde.iso I noticed a mistake in lazarus version.inc seems to prevent Lazarus from running correctly.

Lazarus was installed from Synaptic, and when trying to run Lazarus it said "wrong version".

Reason: version.inc in /lazarus/ide/ contains '2.0.10+dfsg-4' but should contain '2.0.10+dfsg-4+b2'.

I edited the file and Lazarus runs fine, but Is it possible to fix the install files? Because I dont think normal Debian users can, and might just end up not using Lazarus.
« Last Edit: October 30, 2021, 09:05:30 am by kapibara »
Lazarus trunk / fpc 3.2.2 / Kubuntu 21.10 - 64 bit

MarkMLl

  • Hero Member
  • *****
  • Posts: 4163
Re: Debian 11 contains wrong Lazarus configuration
« Reply #1 on: October 30, 2021, 09:55:46 am »
/What/ is reporting that message: Synaptic during installation or Lazarus when it attempts to start?

I can confirm that Debian is distributing 2.0.10+dfsg-4 from its standard repository but haven't gone further since I don't want to mess up running systems.

This is primarily a Debian problem: have you raised a bug report?

MarkMLl
MT+86 & Turbo Pascal v1 on CCP/M-86, multitasking with LAN & graphics in 128Kb.
Pet hate: people who boast about the size and sophistication of their computer.
GitHub repositories: https://github.com/MarkMLl?tab=repositories

kapibara

  • Hero Member
  • *****
  • Posts: 561
Re: Debian 11 contains wrong Lazarus configuration
« Reply #2 on: October 30, 2021, 10:26:06 am »
Hi, it's Lazarus reporting this, attempting to startup.

I haven't bugreported this. Who puts these files together? (version.inc)
Lazarus trunk / fpc 3.2.2 / Kubuntu 21.10 - 64 bit

MarkMLl

  • Hero Member
  • *****
  • Posts: 4163
Re: Debian 11 contains wrong Lazarus configuration
« Reply #3 on: October 30, 2021, 10:57:15 am »
Hi, it's Lazarus reporting this, attempting to startup.

I haven't bugreported this. Who puts these files together? (version.inc)

The Debian maintainers. Report it there unless there's also a problem in the files from https://www.lazarus-ide.org/index.php?page=downloads

MarkMLl
MT+86 & Turbo Pascal v1 on CCP/M-86, multitasking with LAN & graphics in 128Kb.
Pet hate: people who boast about the size and sophistication of their computer.
GitHub repositories: https://github.com/MarkMLl?tab=repositories

dbannon

  • Hero Member
  • *****
  • Posts: 2021
    • tomboy-ng, a rewrite of the classic Tomboy
Re: Debian 11 contains wrong Lazarus configuration
« Reply #4 on: October 30, 2021, 11:40:05 am »
Yes, the problem is that the numbers after the dash in a deb package relate to packaging changes. To the left of the dash, its changes to the 'upstream', ie Lazarus changes.

So, if they, debian, change the content of the version.inc file, they have to rev the full version number, if they do some tweak to the packaging, they just change the number after the dash.

They must have done that tweak, reved the number after the dash but not the number in version.inc (because, obviously, that would require changing the full release...)

Its a joke .....

I have started a discussion with someone within the pascal dev team on that topic already, in a slightly related context, no response yet.

Davo
Lazarus 2, Linux (and reluctantly Win10, OSX)
My Project - https://github.com/tomboy-notes/tomboy-ng

 

TinyPortal © 2005-2018