Forum > Free Pascal

Preparing FPC 3.2.4, point out road blocks now

(1/7) > >>

FPK:
Currently we are in the process of preparing the 3.2.4 release, mainly by merging stuff from main into fixes. If there are any problems with 3.2.2 prevent you from using 3.2.2, it is now the time to point this out :), i.e. if you are stuck with 3.0.4 for some reasons.

marcov:
Test with the FIXES_3_2 branch, FPC 3.2.3 that is.

Alextp:
I wonder when the FreeBSD patch will be merged? https://github.com/Alexey-T/CudaText/blob/master/doc/freebsd-v12-support-for-fpc32.patch

Fred vS:

--- Quote from: FPK on October 25, 2021, 07:57:25 am ---Currently we are in the process of preparing the 3.2.4 release, mainly by merging stuff from main into fixes. If there are any problems with 3.2.2 prevent you from using 3.2.2, it is now the time to point this out :), i.e. if you are stuck with 3.0.4 for some reasons.

--- End quote ---

Hello.

Nice!

Please, if possible, could you make work -Cg -k-pie -k-znow for Linux?

See here:
https://forum.lazarus.freepascal.org/index.php/topic,56842.0.html

It works perfectly with fpc 3.0.4 and fpc 3.3.1.

You may test it compiling a application using BGRABitmap or Zeos lib, no luck with fpc 3.2.0 or 3.2.2 but ok with fpc 3.0.4 / 3.3.1.

Thanks.

PS: It would be super great if this could be fixed:
https://gitlab.com/freepascal.org/fpc/source/-/issues/32367
But yes, I know, I dream and ask too much for this.

Fre;D

Fred vS:

--- Quote from: Alextp on October 25, 2021, 12:49:26 pm ---I wonder when the FreeBSD patch will be merged? https://github.com/Alexey-T/CudaText/blob/master/doc/freebsd-v12-support-for-fpc32.patch

--- End quote ---

Yes, please, mainly changing with this:


--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} --- if target_info.system in (systems_openbsd+systems_freebsd+[system_x86_64_dragonfly]) then LdProgram:='ld.bfd';
And the rest of the patch too. ( Thanks Alex )

Navigation

[0] Message Index

[#] Next page

Go to full version