Recent

Author Topic: need Help with PascalScada install  (Read 3799 times)

microguy

  • New Member
  • *
  • Posts: 47
need Help with PascalScada install
« on: October 21, 2021, 04:38:59 am »
I am trying to install PascalScada on Lazarus. I did update Lazarus to get the latest version 2.0.12 then download Pascalscada. I install full.ipk and got an error. I am not sure how to fix it. the error message is "BGRATypewriter” in the function “function TBGRACustomTypeWriter.GetGlyphBox()” in line 595 “if g = nil then result := TAffineBox.EmptyBox else “  Can someone help me with it? I would like to use Modbus with several Arduino.

af0815

  • Hero Member
  • *****
  • Posts: 771
Re: need Help with PascalScada install
« Reply #1 on: October 21, 2021, 06:57:45 am »
Did you install PascalScada with OPM or another Source ?

I have no Problem with the Version 0.7.7.0 from OPM. It install the correct depencies like BGRAControls.
« Last Edit: October 21, 2021, 07:01:33 am by af0815 »
regards
Andreas

microguy

  • New Member
  • *
  • Posts: 47
Re: need Help with PascalScada install
« Reply #2 on: October 22, 2021, 02:55:04 am »
Where do we install OPM?  from PascalScada.com? I could not find it. I download PascalSCADA_0.7.5.tar.bz2 from https://sourceforge.net/projects/pascalscada/files/0.7.5/   Can you tell me where I can find OPM and how to install it? I could not find instruction for it. I might have overlook.

microguy

  • New Member
  • *
  • Posts: 47
Re: need Help with PascalScada install
« Reply #3 on: October 22, 2021, 03:43:00 am »
OK I think you mean Online Package Manager.  I open it from the package then click on OPM then look for PascalScada and run Install. I use the Install from repository then it did unzip files then stop for  1/12 Opening package "bgrabitmappack.ipk"

af0815

  • Hero Member
  • *****
  • Posts: 771
Re: need Help with PascalScada install
« Reply #4 on: October 22, 2021, 09:40:07 am »
Have you removed the old sources before you use the OPM (= Online Package Manager - you are right). The same with the first try of BGRA* and make a clean recompile of Lazarus !

What version of fpc/lazarus did you have ?

This version were installed/working by me without a problem
Lazarus 2.0.13 r64894M FPC 3.2.2 i386-win32-win32/win64
Lazarus 2.3.0 rv1.4.4-13496-g1d740fac9e / 65500 FPC 3.2.2 x86_64-win64-win32/win64 (yet tested, no problem)

Test:
Install with OPM (on a clean lazarus/fpc)
1 ) bgrabitmappack  (Version 11.3.1.0 i have) out of the package BGRABitmap
2 ) pascalscada_dsgn and pascalscada_hmi (0.7.7.0) this will incluse pascalscada and pascalscada_common automatic

With this steps i have no problem and i do not use pascalscada_full and pascalscada_db here.


regards
Andreas

microguy

  • New Member
  • *
  • Posts: 47
Re: need Help with PascalScada install
« Reply #5 on: October 23, 2021, 05:04:28 am »
Have you removed the old sources before you use the OPM (= Online Package Manager - you are right).

Me - I am not sure what to remove the old source before use OPM.

The same with the first try of BGRA* and make a clean recompile of Lazarus !

What version of fpc/lazarus did you have ?

Me - Here is what I have on Lazarus    version #: 2.0.12 Date: 2021-02-21
FPC Version: 3.2.0 SVN Revision: 64642    x86_64-win64-win32/win64

Me - I use PascalSCADA_0.7.5.tar.bz2

This version were installed/working by me without a problem
Lazarus 2.0.13 r64894M FPC 3.2.2 i386-win32-win32/win64
Lazarus 2.3.0 rv1.4.4-13496-g1d740fac9e / 65500 FPC 3.2.2 x86_64-win64-win32/win64 (yet tested, no problem)

Me - I am not sure. How to fix it.

Test:
Install with OPM (on a clean lazarus/fpc)
1 ) bgrabitmappack  (Version 11.3.1.0 i have) out of the package BGRABitmap
2 ) pascalscada_dsgn and pascalscada_hmi (0.7.7.0) this will incluse pascalscada and pascalscada_common automatic

With this steps i have no problem and i do not use pascalscada_full and pascalscada_db here.

microguy

  • New Member
  • *
  • Posts: 47
Re: need Help with PascalScada install
« Reply #6 on: October 24, 2021, 05:49:50 am »
I finally got PascalScada to install on Lazarus from OPM. I use a different version.  Lazarus 2.2 ORC!-fpc-3.2.2-win64.exe. Now I need to figure out how to use it.

 

TinyPortal © 2005-2018