Recent

Author Topic: installed sqlite3laz and ide startup fails  (Read 2099 times)

SA.Blackmon

  • New Member
  • *
  • Posts: 37
  • Just an old retired guy practicing what he enjoys.
installed sqlite3laz and ide startup fails
« on: October 14, 2021, 03:09:39 am »
I have been working on this most of the day. I have tried  lazbuild -dKeepInstalledPackages. (never found a config directory.)

I have deleted every file/directory with sqlite in the name from my lazarus folder. The environmentoptions.xml file has very little in it (attached).

I have reinstalled lazarus and had to rebuild all my components. (Like to not have to do that again.)

I really would like to get back to work. Where should I go from here?

I guess if I do not get a reply pretty quick I will uninstall/reinstall lazarus and go through that rigamarole.

Thank you.
Thank you for your help,
Sherril

paweld

  • Sr. Member
  • ****
  • Posts: 312
Re: installed sqlite3laz and ide startup fails
« Reply #1 on: October 14, 2021, 07:12:44 am »
place the sqlite library in the lazarus directory
Best regards
paweld

af0815

  • Hero Member
  • *****
  • Posts: 772
Re: installed sqlite3laz and ide startup fails
« Reply #2 on: October 14, 2021, 07:28:57 am »

On Windows: Better defined - Place the right sqlite library with the correct bitness of your Lazarus installation in the directory where your lazarus.exe resides. Eg. a 32 Bit compiled Lazarus need a 32Bit version of the sqlite.dll. And a 64 Bit Version of Lazarus need the 64Bit version of the sqlite.dll.

The background - Lazarus designer use the sqlite dll in the same dir where Lazarus reside. The compiled program use the dll in its directory or path.

see https://forum.lazarus.freepascal.org/index.php?topic=40462.0
regards
Andreas

SA.Blackmon

  • New Member
  • *
  • Posts: 37
  • Just an old retired guy practicing what he enjoys.
Re: installed sqlite3laz and ide startup fails
« Reply #3 on: October 14, 2021, 07:35:52 pm »
SOLVED.

Maybe the root, or the beginning of my problem (after I caused it by installing the sqlite component) was the sqlite*.dll.

Besides the attempts already mentioned, I had gone looking for the dll and found nothing but sqlite3.dll; certainly, not a match. I put it in the lazarus directory and, of course, the problem persisted.

Then, I started the bumbling around in an effort to find a fix. I really screwed things up. Then, I got "Application will not start... 0xc000007b" error.

That took a while. Finally, I downloaded (and paid for) Restoro, an application for finding and repairing (the paid for part) low level windows errors.

Still had the 0xc000007b error.

Uninstalled lazarus and wiped the lazarus directory.

Installed lazarus and, voila, it starts, now.

Thank you for all your efforts.

Sherril
Thank you for your help,
Sherril

 

TinyPortal © 2005-2018