Recent

Author Topic: ZConnection with Oracle keep going in error  (Read 2604 times)

lander

  • New Member
  • *
  • Posts: 31
ZConnection with Oracle keep going in error
« on: October 12, 2021, 10:14:05 pm »
(https://i.postimg.cc/ryPydbTZ/Immagine.png)

I have Win10, Lazarus 2.0.12 32bit (fcup), oci.dll 32 bit of instant client 19 and 21. When I try retry and retry it then works but everytime I should lose a lot of time. I don't know the event that make it works. I simply close lazarus, change oci.dll 10 times...
Is there a way to make it works forever without 100 attempts? :D

Edit: just another attempt: I duplicated oci.dll with another name, it connected.
« Last Edit: October 13, 2021, 12:49:24 am by lander »

loaded

  • Sr. Member
  • ****
  • Posts: 373
Re: ZConnection with Oracle keep going in error
« Reply #1 on: October 13, 2021, 11:13:31 am »
I had a similar problem a long time ago, I'm not sure, but some of the following solved my problem.
-First of all, you can close your antivirus program and try, if the problem is resolved, add the Lazarus exe path and the project path you are using to the exclusions.
-Run Lazarus with Administrator Rights. Make this feature permanent in the compatibility settings.
-Stop the Windows file scanning and indexing service.
If I remember anything else, I'll add it here. ;D
If Ide=Lazarus 2.0.10 32 Bit and Os=Win 10 Home 64 Bit then Get up and do something useful! Because God is the helper of those who start again;

lander

  • New Member
  • *
  • Posts: 31
Re: ZConnection with Oracle keep going in error
« Reply #2 on: October 13, 2021, 09:10:43 pm »
I applied your suggestions. Thank you!
Consider I'm now using "system" user cause this database is for development testing purposes. Should I create a new user for testing or it's not important?
« Last Edit: October 13, 2021, 09:30:18 pm by lander »

loaded

  • Sr. Member
  • ****
  • Posts: 373
Re: ZConnection with Oracle keep going in error
« Reply #3 on: October 14, 2021, 07:02:28 am »
I couldn't quite understand what you were saying due to my poor English (I don't actually have any).
If by User you mean the Win10 side, it doesn't matter as long as you can interfere with the relevant settings!
But if you are talking about database;
If you have or will add a record deletion in the database, it may be useful to create a different user to prevent unwanted situations in the future.
Other than security, you won't notice much difference in terms of performance.
Of course, these are my thoughts, I don't know what the Masters would say.
If Ide=Lazarus 2.0.10 32 Bit and Os=Win 10 Home 64 Bit then Get up and do something useful! Because God is the helper of those who start again;

marsupilami79

  • New Member
  • *
  • Posts: 16
Re: ZConnection with Oracle keep going in error
« Reply #4 on: October 14, 2021, 05:29:36 pm »
Hello lander,

(https://i.postimg.cc/ryPydbTZ/Immagine.png)
This could be a windows problem. Zeos generates this error when Windows fails to load the library. Which version of Zeos do you use?

Best regards,

Jan
« Last Edit: October 14, 2021, 05:31:56 pm by marsupilami79 »
Zeos developer

lander

  • New Member
  • *
  • Posts: 31
Re: ZConnection with Oracle keep going in error
« Reply #5 on: October 14, 2021, 07:50:12 pm »
I have solved the problem.
After following loaded suggestions I also applied such queries:

BEGIN
  FOR sess IN (SELECT sid,serial# FROM v$session WHERE status<>'INACTIVE')
  LOOP
      EXECUTE IMMEDIATE 'alter system kill session ''' || sess.sid  || ','
        || sess.serial# || ''' immediate';
  END LOOP;
END;
 
SELECT * FROM V$SESSION
 
ALTER SYSTEM KILL SESSION WHERE status LIKE '%active%';

ALTER PROFILE DEFAULT LIMIT IDLE_TIME 1;

 

TinyPortal © 2005-2018