Forum > Editor

Keys Not rendering properly in Editor

<< < (2/2)

Martin_fr:

--- Quote from: abtaylr on October 10, 2021, 08:01:22 pm ---As mentioned in my initial comment, using the ALT-GR + Shift + S with Linux German Keyboard is not rendering anything to the screen. I will try to change the the font to the one mentioned.

--- End quote ---
Ok, then I misunderstood you. I saw the image, and I saw that the letter is there, but only partly displayed. So I thought you had typed it.


As for the problem with the typing...
I don't have Kubuntu, it works for me on Ubuntu (though that is in a VM).

One thing to make sure is that the IDE keymap does not override the key combo.
AltGr is in some case handled as Alt+Ctrl.
An Alt+Ctrl+S opens (or focuses) the Stack-Window.
However An Alt+Ctrl+Shift+S has no IDE action.

Maybe the IDE stops the Key-Combo.
Go to Tools > Options > Editor > Keymap
and use the search to search for Alt+Ctrl+Shift+S
It should come up empty. If not, then that may be the problem...

Otherwise, someone with more understanding of Linux may be able to help.

Also, if you are in the IDE, and you type into a TEdit => does it work then?
This might be a sign that there is an issue in the GTK2 Interface of the LCL (I don't have any detailed knowledge there / just a guess / and also something someone with more experience would need to look at.)

A very long shot....
There is some disabled experimental code for the Key handling in the LCL. I can't really see how it could affect your issue.
But maybe enabling it will help somehow.

The cod is in the 2.2RC1 / It is NOT in any 2.0.x
You would need to recompile the IDE with -dWITH_GTK2_IM
But as I said very far fetched....

Even more far fetched: Compile with -dWITHOUT_GTK_DOUBLEKEYPRESS_CHECK
(and this last one may add issues with keystrokes producing duplicated chars)



Navigation

[0] Message Index

[*] Previous page

Go to full version