Forum > macOS / Mac OS X

First Pascal Application

<< < (4/5) > >>

dbannon:
Thaddy, yes, there are still some issues on the Mac, but just about all software has issues of some sort. A functional install of FPC/Lazarus is relatively easy and many people are using it right now.

I only use my (poor old) Mac to do prerelease testing, all development is done on Linux but thats just because the Mac UI drives me mad! 

Jon, my MacOS install is probably not typical and may well be bad advice. I am a long term Unix user. (Although Thaddy once called me a Windows user and has still not apologized  :) ) I rewrote the Wiki page I referred you to earlier some years ago and had hoped it has been extensively rewritten since then, sadly I recognise much of the wording ....

trev would be a lot more help here but it does not seem he is around.

Further to Handoko's advice for finding errant Lazarus file, when Lazarus starts up the first time, it creates a set of config files in (default)  $HOME/.lazarus. If you re-install a different way it will probably look there and assume the files there apply, nominally, version number is the same.  So, part of your clean out exercise is to remove, completely, .lazarus from your home directory. It gets rebuilt automatically.

In my humble opinion, the best way to install FPC/Lazarus (on any platform) is to use the supplied binary install packages for FPC and FPC-SRC from sourceforge, links in the wiki page.  Get that working, test it and then download the Lazarus source and compile it. FPC is a compiler, its a good one, compiling is what its good at !

That way you can put your Lazarus install in user space, where you want it and you have a full understanding of where it is and which version you are using. It does not need to be on your path, you cd to the install directory and start from there.

Details -
1. You do not need to use git or svn to down load Lazaus source. Anyone other than Lazarus developer should (IMHO) just download a zip file. Move an existing install out of the way, unzip the new one, change into the dir, type "make all LCL_PLATFORM=cocoa CPU_TARGET=x86_64 bigide". If its trunk or Fixes, repeat every few months.

2. I always use the --PCP=somewhere option to lazarus (or better, create a lazarus.cfg in your lazarus directory with that same info). Again, just so I am sure which files are being used.

3. To start a source installed Lazarus, cd into the install dir and start from there. Or create a bash script, I keep mine in ~/bin, like this (in my case 'trunk' is my Lazarus install dir below $HOME/bin/Lazarus, you will probably have different names) -


--- Code: Bash  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---#!/bin/bashLAZDIR="trunk"cd "$HOME/bin/Lazarus/$LAZDIR"open "$HOME/bin/Lazarus/$LAZDIR"/lazarus.app --args "--pcp=$HOME/.$LAZDIR"
4. You really should not be taking advice about MacOS from an old Unix hack.

Davo


trev:
I'm missing for a day and...  :o

The Mac Portal on the Wiki has lots of useful information including:

* Installing Lazarus on macOS

* Uninstalling Lazarus on macOS

If you're still having issues, please follow the uninstallation instructions and start afresh.

Gustavo 'Gus' Carreno:
Hey Trev,

<completely_off_topic_and_dripping_sarcasm>

--- Quote from: trev on October 11, 2021, 02:52:00 am ---I'm missing for a day and...  :o

--- End quote ---

What do you mean you need some personal time!?!?!?
Isn't the 30m power nap you take each nite enough for that!?!?
<insert_whip_cracking_gif/>

</completely_off_topic_and_dripping_sarcasm>

Cheers,
Gus

Thaddy:

--- Quote from: Gustavo 'Gus' Carreno on October 11, 2021, 02:57:18 am ---Isn't the 30m power nap you take each nite enough for that!?!?

--- End quote ---
Huh? That is IONS.

Isn't 30 ┬Ás enough for a power nap...? (I am being generous here)

Jon Trepte:
First let me thank all how have taken the time to assist me. Especially Thaddy and Handoko. I'm a bit closer now in that I can get thing to compile but I still have one problem left. When I run an empty project I get the following.

Compile Project, CPU: i386, Target: /Users/jontrepte/tmp/project1: Exit code 1,
Errors: 1
Linking /Users/jontrepte/tmp/project1
ld: framework not found Cocoa
An error occurred while linking
Error: Error while linking

Any ideas? Maybe something to do with Xcode

Running Xcode 13
fps 3.3.3
Lazarus 2.0.12

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version