Forum > Pas2JS

pá2js package not compile

(1/1)

__thinhorigami:
Hi! all.
today is my first day using pas2js and i get 1 error when compiling pas2js packages. when i compile pas2js_rtl.lpk package i get 1 message
web.pas (1995,53) Error: Expected "," or ":".

I compile the pas2js package in Lazarus 2.0.12 and pas2js here https://github.com/fpc/pas2js/tree/release_2_0_0

Can someone help me with this, Thanks all.

PierceNg:
The wiki page https://wiki.freepascal.org/lazarus_pas2js_integration does not mention compiling pas2js_rtl.lpk. It's been a while since I installed pas2js and my installation is working.

Can you describe in more detail the steps you took. Also, what OS?

__thinhorigami:
but how can i use ctrl + space when not compiling, moreover my webwidget package get same error when compiling. I use Windows 10 ver 21H1

PascalDragon:

--- Quote from: __thinhorigami on October 02, 2021, 05:08:10 pm ---today is my first day using pas2js and i get 1 error when compiling pas2js packages. when i compile pas2js_rtl.lpk package i get 1 message
web.pas (1995,53) Error: Expected "," or ":".
--- End quote ---

You must not compile the package from within the IDE using the package's Compile button, cause that will use the FPC compiler instead of the pas2js transpiler. You simply need to start a new Pas2JS project and add the pas2js_rtl package as a requirement (if it isn't already) and then compile your project.


--- Quote from: __thinhorigami on October 02, 2021, 05:35:12 pm ---but how can i use ctrl + space when not compiling, moreover my webwidget package get same error when compiling. I use Windows 10 ver 21H1

--- End quote ---

Identifier completion does not depend on the compilation of a package, the IDE only needs to know about it and that is achieved by opening that package once and afterwards you only need to add it as a requirement for your project.

mdalacu:
@PascalDragon Hi, please, can you provide an video how to setup pas2js / pas2jsdesign and install lazwebwidgets.lpk?
I was able to install pas2jsdesgn and create hello world example.
I want to install the lazarus components for pas2js.
I am using pas2js 2.0.6
Is this page for something different then ..pas2js_2.0.6/packages/webwidget/lazwebwidgets.lpk?
https://github.com/pascaldragon/Pas2JS_Widget

I have tried everything but no luck
This is the error when i try to install lazwebwidgets.lpk
Compile package FCL 1.0.1: Exit code 2, Errors: 1
Fatal: parameter -gl: unknown parameter "-gl". Use -h for help.

Thank you very much.

Navigation

[0] Message Index

Go to full version