Forum > macOS / Mac OS X

Compile Error (Darain/AArch64)

<< < (3/3)

FPK:

--- Quote from: Jonas Maebe on September 18, 2021, 07:11:52 pm ---
--- Quote from: FPK on September 18, 2021, 10:59:03 am ---
--- Quote from: Jonas Maebe on September 13, 2021, 06:26:47 pm ---On Darwin you need to add -Xg in addition to -gl (and then copy the ppca64.dSYM directory from the compiler directory next to the ppca64 binary). This will also require trunk, or a fairly recent version of the fixes branch.

--- End quote ---

The copying shouldn't be needed anymore except if the crash is in ppc3 (because if ppc3 is compiled with this name, the compare of the executables will fail), see https://gitlab.com/freepascal.org/fpc/source/-/commit/b3bf183fd37dcb46c4a89fc48005cb68dbed4a50 and friends.

--- End quote ---
I meant you need to copy the .dSYM bundle to the installation directory, because afaik our Makefiles don't do that with "make install".

--- End quote ---

Indeed, that's true.

olly:
I get a similar issue here on a RPI4.
https://gitlab.com/freepascal.org/fpc/source/-/issues/39336

Grahame Grieve:
To reproduce this, install packages from the following repos:
https://github.com/dezlov/PascalTZ
https://github.com/grahamegrieve/delphi-markdown

Then try and compile /packages/fhir_fsl.pas in https://github.com/grahamegrieve/fhirserver on a Mac M1

Jonas Maebe:
Can you try again with latest trunk?

Grahame Grieve:
Seems to be - thanks!

(at least, now I have other problems to sort out, which appear to be linking errors)

Navigation

[0] Message Index

[*] Previous page

Go to full version