Recent

Author Topic: Can't install lazarus-2.2.0RC1 from sources on Ubuntu 20.04.3 (Linux 5.11.0-27).  (Read 1426 times)

eugene.raynor

  • Newbie
  • Posts: 3
Can't install lazarus-2.2.0RC1 from sources on Ubuntu 20.04.3 (Linux 5.11.0-27).
Latest version of fpc-3.2.2.x86_64-linux already installed from sources.
See error below.

af0815

  • Hero Member
  • *****
  • Posts: 728
Read the names of the needed depencies more carefull
regards
Andreas

renabor

  • Jr. Member
  • **
  • Posts: 73
In order to compile freepascal and lazarus from source i have installed all those debs:

Code: Bash  [Select][+][-]
  1. sudo apt-get install -y make build-essential p7zip-full gdb
  2. sudo apt-get install -y libcairo2-dev libpango1.0-dev libatk1.0-dev libghc-x11-dev
  3. sudo apt-get install -y libgtk2-gladexml-perl libgtk2.0-bin libgtk2.0-cil libwxgtk3.0-0v5
  4. sudo apt-get install -y libgtk2.0-dev libgdk-pixbuf2.0-dev libgpm-dev fakeroot libncurses5-dev libtinfo-dev
  5.  
FPC 3.2.2 | Lazarus 2.0.13 | Kubuntu 21.04 64bit

Alextp

  • Hero Member
  • *****
  • Posts: 1416
    • UVviewsoft
I suggest that Lazarus site shows this info about these needed APT packages.

winni

  • Hero Member
  • *****
  • Posts: 2715
Hi!

The messages "crti.o not found" and "crti.n not found" tells that your gcc is not uptodate.

Before you continue make an update of your system:

Code: Bash  [Select][+][-]
  1. aptitude update

Winni

prof7bit

  • Full Member
  • ***
  • Posts: 141
In order to compile freepascal and lazarus from source i have installed all those debs:

Code: Bash  [Select][+][-]
  1. sudo apt-get install -y make build-essential p7zip-full gdb
  2. sudo apt-get install -y libcairo2-dev libpango1.0-dev libatk1.0-dev libghc-x11-dev
  3. sudo apt-get install -y libgtk2-gladexml-perl libgtk2.0-bin libgtk2.0-cil libwxgtk3.0-0v5
  4. sudo apt-get install -y libgtk2.0-dev libgdk-pixbuf2.0-dev libgpm-dev fakeroot libncurses5-dev libtinfo-dev
  5.  

Since when does Lazarus require 7zip, ncurses, wxWidgets, and Haskell? Haskell???
Who has made this list? Is this a joke?

Normally on a virgin *buntu box I just need gtk-2something-dev and if I want to build qt5 I also need libqt5pas1-dev. Not much more than that.

And to deploy my applications (with Qt5) I just need to install libqt5pas1 (without "-dev"), this pulls in everything that is needed.

Code: [Select]
--(bernd@Saturn)-(/home/bernd)--
--($)-- apt-rdepends --build-depends --follow=DEPENDS lazarus
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
lazarus
  Build-Depends: debhelper (>= 11~)      <-- only if you want to make .deb packages
  Build-Depends: dh-exec (>= 0.22)       <-- only if you want to make .deb packages
  Build-Depends: fp-utils (>= 3.2.0~)    <-- of course not if you have it already installed otherwise
  Build-Depends: fpc (>= 3.2.0~)         <-- of course not if you have it already installed otherwise
  Build-Depends: fpc-source (>= 3.2.0~)  <-- of course not if you have it already installed otherwise
  Build-Depends: libgtk2.0-dev
  Build-Depends: libqt5pas-dev (>= 2.6~beta-6~)
  Build-Depends: po-debconf            <-- only if you want to make .deb packages
  Build-Depends: rdfind                <-- no idea, probably also only for .deb
  Build-Depends: symlinks              <-- dito.
--(bernd@Saturn)-(/home/bernd)--
--($)--
« Last Edit: October 02, 2021, 06:11:54 pm by prof7bit »

prof7bit

  • Full Member
  • ***
  • Posts: 141
The messages "crti.o not found" and "crti.n not found" tells that your gcc is not uptodate.
I found this on one of my colleagues machines caused by an outdated fpc.cfg, it pointed to a non existing directory (version numbers in directory name changed), probably due to an OS update long after fpc has been installed.

 

TinyPortal © 2005-2018