Forum > Linux

Can't install lazarus-2.2.0RC1 from sources on Ubuntu 20.04.3 (Linux 5.11.0-27).

(1/2) > >>

eugene.raynor:
Can't install lazarus-2.2.0RC1 from sources on Ubuntu 20.04.3 (Linux 5.11.0-27).
Latest version of fpc-3.2.2.x86_64-linux already installed from sources.
See error below.

af0815:
Read the names of the needed depencies more carefull

renabor:
In order to compile freepascal and lazarus from source i have installed all those debs:


--- Code: Bash  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---sudo apt-get install -y make build-essential p7zip-full gdbsudo apt-get install -y libcairo2-dev libpango1.0-dev libatk1.0-dev libghc-x11-devsudo apt-get install -y libgtk2-gladexml-perl libgtk2.0-bin libgtk2.0-cil libwxgtk3.0-0v5 sudo apt-get install -y libgtk2.0-dev libgdk-pixbuf2.0-dev libgpm-dev fakeroot libncurses5-dev libtinfo-dev 

Alextp:
I suggest that Lazarus site shows this info about these needed APT packages.

winni:
Hi!

The messages "crti.o not found" and "crti.n not found" tells that your gcc is not uptodate.

Before you continue make an update of your system:


--- Code: Bash  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---aptitude update
Winni

Navigation

[0] Message Index

[#] Next page

Go to full version