Recent

Author Topic: Auto Remove needs only a half second  (Read 2014 times)

winni

  • Hero Member
  • *****
  • Posts: 2715
Auto Remove needs only a half second
« on: August 21, 2021, 06:11:42 pm »
Hi!

Strange behaviour of "Auto Remove empty methods":

If I click in the events Tab of the OI to create a procedure for an event, then this procedure has a lifetime of around half a second. Then it is auto removed.

So I have to manage some acrobatic things:

Click on the button with the mouse to create the procedurewith the right hand.
A twinkle later I type at least one char after the "begin" with the left hand.
With the only use, that the procedure is not deleted.

Where is the reason for this strange behaviour? And where can I stop it?

Winni

Bart

  • Hero Member
  • *****
  • Posts: 4477
    • Bart en Mariska's Webstek
Re: Auto Remove needs only a half second
« Reply #1 on: August 21, 2021, 10:47:30 pm »
Auto remove empty methods is supposed to remove them on compile AFAIK.

Bart

wp

  • Hero Member
  • *****
  • Posts: 8905
Re: Auto Remove needs only a half second
« Reply #2 on: August 21, 2021, 11:00:12 pm »
The described behaviour is unusual. For me, "AutoRemove of empty methods" becomes active only when the form is saved (or compiled - but this also triggers a save, so I think this is the same).

Rename your Lazarus config folder to restart with default settings - just for a test to see whether the issue goes away (you can restore your old settings afterwards by renaming the config folder back).
Mainly Lazarus trunk / fpc 3.2.0 / all 32-bit on Win-10, but many more...

winni

  • Hero Member
  • *****
  • Posts: 2715
Re: Auto Remove needs only a half second
« Reply #3 on: August 22, 2021, 12:39:26 am »
Hi!

Thanx @Bart and @wp.

But I am the idiot.
Last week I installed the package autosave.

That created the hassle. Just removed it.

Now the empty procedures are removed on every "save" again.

Thanx Winni

Bart

  • Hero Member
  • *****
  • Posts: 4477
    • Bart en Mariska's Webstek
Re: Auto Remove needs only a half second
« Reply #4 on: August 22, 2021, 10:15:55 am »
Last week I installed the package autosave.

That created the hassle. Just removed it.

That's a nice "side effect" of this package then.
Please report this to the maintainer of that package (or, if it comes with Lazarus: file a bugreport).

Bart

 

TinyPortal © 2005-2018