Forum > Debugger

Problems with the debugger

(1/1)

JD:
Hi there everyone,

A few days ago, the debugger on my Lazarus installation on Windows 10 just stopped working. I can no longer debug one of my programs. It pauses on breakpoints normally but when I press F8 or F9, the debugger seems to fail. However when I run without debugging, the program works as expected.

I've tried to reset the debugger from the menu Run > Reset Debugger but it did not seem to work.

Would really appreciate any help.

Cheers,

JD

Martin_fr:
So what version of Lazarus and fpc?
Which debugger gdb or fpdebug?
Any cross compiling/debugging between bitness?

What happens when you press F9? Does the app start (with a debugger configured)?
Are the breakpoints red, with a green check? (once the debugger runs)?
Are the blue dots in the gutter shown?

"Reset the debugger" does reset the current instance. It does not reset the config. So if you made a change there.....

Check your project settings too.
- Ideally dwarf
- no stripping
- no external debug info (for narrowing it down)
- no smartlinking
- -O- no optimization
- no inlining

possibly a logfile
https://wiki.lazarus.freepascal.org/GDB_Debugger_Tips#Log_info_for_debug_session

Navigation

[0] Message Index

Go to full version