Author Topic: Lazarus install not working  (Read 4358 times)


  • Newbie
  • Posts: 2
Lazarus install not working
« on: August 06, 2021, 09:11:42 pm »

I'm completely new to Lazarus and am trying to install in on my windows 10 machine.

Here's what I've done so far:

1) downloaded lazarus-2.0.12-fpc-3.2.0-win64.exe and ran it - install completed successfully and i'm able to make simple desktop aps with it.
2) Next I wanted  a Docked Version of Lazarus IDE so went to Package.>Install/Uninstall and selected anchordockingdsgn 1.0 then clicked Install selection follows by save and rebuild IDE.

This then runs for a while but fails on the following error message -

lazarus.pp(57,3) Fatal: Cannot find Interfaces used by Lazarus, incompatible ppu=C:\lazarus\lcl\units\x86_64-win64\win32\interfaces.ppu, package LCL

So far I have uninstalled Lazarus and reinstalled still with the same result.

An help would be much appreciated.


  • Administrator
  • Hero Member
  • *
  • Posts: 8754
  • Debugger - SynEdit - and more
    • wiki
Re: Lazarus install not working
« Reply #1 on: August 06, 2021, 10:41:15 pm »
Please, repeat all the steps until the error.

Then go to menu: Tools > Configure Build Lazarus.
You will find a checkbox "Clean all" =>check it.
Then press the "build" button.
This will again take a bit of time, but should work.

If not, check you systems PATH environment.
Does it contain Delphi, or some C, C++ environment?
In rare cases those contain an incompatible "make.exe". But the error does not point to that.

Please go to menu: View > IDE Internals > About IDE
And report the content of the page shown. Thanks.

I have seen this issue happen, when people had more than one version of Lazarus installed. But as you are new, I assume you downloaded just the one?


  • Newbie
  • Posts: 2
Re: Lazarus install not working
« Reply #2 on: August 08, 2021, 02:01:02 pm »

Great thanks. I did the clean all as mentioned and now it works fine.

Thanks Again.


TinyPortal © 2005-2018